CVE-2020-26890
CVE-2020-26890
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Matrix Synapse before 1.20.0 erroneously permits non-standard NaN, Infinity, and -Infinity JSON values in fields of m.room.member events, allowing remote attackers to execute a denial of service attack against the federation and common Matrix clients. If such a malformed event is accepted into the room's state, the impact is long-lasting and is not fixed by an upgrade to a newer version, requiring the event to be manually redacted instead. Since events are replicated to servers of other room members, the impact is not constrained to the server of the event sender.
CVSS 8.7 · High · EPSS 3.0% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
matrix-synapse PyPI
- Versions
- 0.33.5
- 0.33.5.1
- 0.33.6
- 0.33.6rc1
- 0.33.7
- 0.33.7rc1
- 0.33.7rc2
- 0.33.8
- 0.33.8rc2
- 0.33.9
- 0.34.0
- 0.34.0.1
- 0.34.0rc1
- 0.34.0rc2
- 0.34.1.1
- 0.99.0
- 0.99.0rc1
- 0.99.0rc2
- 0.99.0rc3
- 0.99.0rc4
- 0.99.1
- 0.99.1.1
- 0.99.1rc1
- 0.99.1rc2
- 0.99.2
- 0.99.2rc1
- 0.99.3
- 0.99.3.1
- 0.99.3.2
- 0.99.3rc1
- 0.99.4
- 0.99.4rc1
- 0.99.5
- 0.99.5.1
- 0.99.5.2
- 0.99.5rc1
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.1.0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc1
- 1.10.0rc2
- 1.10.0rc3
- 1.10.0rc5
- 1.10.1
- 1.11.0
- 1.11.0rc1
- 1.11.1
- 1.12.0
- 1.12.0rc1
- 1.12.1
- 1.12.1rc1
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.4rc1
- 1.13.0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.0rc3
- 1.14.0
- 1.14.0rc1
- 1.14.0rc2
- 1.15.0
- 1.15.0rc1
- 1.15.1
- 1.15.2
- 1.16.0
- 1.16.0rc1
- 1.16.0rc2
- 1.16.1
- 1.17.0
- 1.17.0rc1
- 1.18.0
- 1.18.0rc1
- 1.18.0rc2
- 1.19.0
- 1.19.0rc1
- 1.19.1
- 1.19.1rc1
- 1.19.2
- 1.19.3
- 1.2.0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.20.0rc1
- 1.20.0rc2
- 1.20.0rc3
- 1.20.0rc4
- 1.20.0rc5
- 1.3.0
- 1.3.0rc1
- 1.3.1
- 1.4.0
- 1.4.0rc1
- 1.4.0rc2
- 1.4.1
- 1.4.1rc1
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.1
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.1
- 1.7.0
- 1.7.0rc1
- 1.7.0rc2
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8.0
- 1.8.0rc1
- 1.9.0
- 1.9.0.dev1
- 1.9.0.dev2
- 1.9.0rc1
- 1.9.1
- Affected ranges
- ECOSYSTEM: < 1.20.0
Update to 1.20.0
matrix-synapse Ubuntu:Pro:18.04:LTS
- Versions
- 0.19.2+dfsg-6
- 0.24.0+dfsg-1
- 0.24.0+dfsg-1ubuntu0.1~esm1
- 0.24.0+dfsg-1ubuntu0.1~esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
matrix-synapse Ubuntu:Pro:20.04:LTS
- Versions
- 1.3.0-1
- 1.4.0-1
- 1.5.0-1
- 1.5.1-1
- 1.6.0-1
- 1.6.1-1
- 1.7.0-2
- 1.7.1-1
- 1.7.2-1
- 1.7.3-1
- 1.8.0-1
- 1.9.0-1
- 1.9.1-1
- 1.10.0-1
- 1.10.0-2
- 1.11.0-1
- 1.11.0-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/matrix-org/synapse/security/advisories/GHSA-4mp3-385r-v63f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U34DPP4ZLOEDUY2ZCWOHQPU5GA5LYNUQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G7YXMMYQP46PYL664JQUXCA3LPBJU7DQ/
- https://nvd.nist.gov/vuln/detail/CVE-2020-26890