CVE-2020-27779
CVE-2020-27779
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in grub2 in versions prior to 2.06. The cutmem command does not honor secure boot locking allowing an privileged attacker to remove address ranges from memory creating an opportunity to circumvent SecureBoot protections after proper triage about grub's memory layout. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
CVSS 7.5 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
grub2
- Versions
- grub 2.06: Affected
No fix published
grub2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.04-16
Update to 2.04-16
grub2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.04-16
Update to 2.04-16
grub2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.04-16
Update to 2.04-16
grub2-signed Ubuntu:Pro:14.04:LTS
- Versions
- 1.22
- 1.23
- 1.24
- 1.25
- 1.26
- 1.27
- 1.30
- 1.31
- 1.32
- 1.33
- 1.34
- 1.34.1
- 1.34.2
- 1.34.3
- 1.34.4
- 1.34.5
- 1.34.6
- 1.34.7
- 1.34.8
- 1.34.9
- 1.34.13
- 1.34.14
- 1.34.16
- 1.34.17
- 1.34.18
- 1.34.20
- 1.34.22
- 1.34.24
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
grub2-signed Ubuntu:18.04:LTS
- Versions
- 1.85
- 1.86
- 1.87
- 1.89
- 1.91
- 1.92
- 1.93
- 1.93.1
- 1.93.2
- 1.93.3
- 1.93.4
- 1.93.5
- 1.93.7
- 1.93.8
- 1.93.10
- 1.93.11
- 1.93.13
- 1.93.14
- 1.93.15
- 1.93.16
- 1.93.18
- 1.93.19
- 1.93.20
- 1.93.21
- 1.93.22
- 1.93.24
- 1.167~18.04.1
- 1.167~18.04.3
- Affected ranges
- ECOSYSTEM: < 1.167~18.04.5
Update to 1.167~18.04.5
grub2-unsigned Ubuntu:18.04:LTS
- Versions
- 2.04-1ubuntu44
- 2.04-1ubuntu44.1
- Affected ranges
- ECOSYSTEM: < 2.04-1ubuntu44.1.2
Update to 2.04-1ubuntu44.1.2
grub2-signed Ubuntu:20.04:LTS
- Versions
- 1.128
- 1.129
- 1.130
- 1.131
- 1.133
- 1.134
- 1.135
- 1.136
- 1.137
- 1.138
- 1.139
- 1.140
- 1.141
- 1.142
- 1.142.1
- 1.142.3
- 1.142.4
- 1.142.5
- 1.142.6
- 1.142.8
- 1.142.9
- 1.142.10
- 1.142.11
- 1.167
- Affected ranges
- ECOSYSTEM: < 1.167.2
Update to 1.167.2
grub2-unsigned Ubuntu:20.04:LTS
- Versions
- 2.04-1ubuntu44
- Affected ranges
- ECOSYSTEM: < 2.04-1ubuntu44.2
Update to 2.04-1ubuntu44.2
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1900698
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZWZ36QK4IKU6MWDWNOOWKPH3WXZBHT2R/
- https://security.gentoo.org/glsa/202104-05
- https://security.netapp.com/advisory/ntap-20220325-0001/
- https://nvd.nist.gov/vuln/detail/CVE-2020-27779