CVE-2020-29565
CVE-2020-29565
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in OpenStack Horizon before 15.3.2, 16.x before 16.2.1, 17.x and 18.x before 18.3.3, 18.4.x, and 18.5.x. There is a lack of validation of the "next" parameter, which would allow someone to supply a malicious URL in Horizon that can cause an automatic redirect to the provided malicious URL.
CVSS 6.1 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
horizon Debian:12
- Affected ranges
- ECOSYSTEM: < 3:18.6.1-1
Update to 3:18.6.1-1
horizon Debian:13
- Affected ranges
- ECOSYSTEM: < 3:18.6.1-1
Update to 3:18.6.1-1
horizon Debian:14
- Affected ranges
- ECOSYSTEM: < 3:18.6.1-1
Update to 3:18.6.1-1
horizon PyPI
- Versions
- 12.0.2
- 12.0.3
- 12.0.4
- 13.0.0
- 13.0.0.0b3
- 13.0.0.0rc1
- 13.0.0.0rc2
- 13.0.1
- 13.0.2
- 13.0.3
- 14.0.0
- 14.0.0.0b1
- 14.0.0.0b2
- 14.0.0.0b3
- 14.0.0.0rc1
- 14.0.0.0rc2
- 14.0.1
- 14.0.2
- 14.0.3
- 14.0.4
- 14.1.0
- 15.0.0
- 15.0.0.0b1
- 15.0.0.0b2
- 15.0.0.0rc1
- 15.0.0.0rc2
- 15.1.0
- 15.1.1
- 15.2.0
- 15.3.0
- 15.3.1
- Affected ranges
- ECOSYSTEM: < 15.3.2
Update to 15.3.2
horizon PyPI
- Versions
- 16.0.0
- 16.1.0
- 16.2.0
- Affected ranges
- ECOSYSTEM: ≥ 16.0.0, < 16.2.1
Update to 16.2.1
horizon PyPI
- Versions
- 17.0.0
- 17.1.0
- 18.0.0
- 18.1.0
- 18.2.0
- 18.3.0
- 18.3.1
- 18.3.2
- Affected ranges
- ECOSYSTEM: ≥ 17.0.0, < 18.3.3
Update to 18.3.3
horizon PyPI
- Versions
- 18.4.0
- 18.4.1
- 18.5.0
- Affected ranges
- ECOSYSTEM: ≥ 18.4.0, < 18.6.0
Update to 18.6.0
horizon PyPI
- Versions
- 15.3.0
- 15.3.1
- 16.0.0
- 16.1.0
- 16.2.0
- 17.0.0
- 17.1.0
- 18.0.0
- 18.1.0
- 18.2.0
- 18.3.0
- 18.3.1
- 18.3.2
- 18.4.0
- 18.4.1
- 18.5.0
- Affected ranges
- ECOSYSTEM: ≥ 15.3.0, < 15.3.2 ∪ ≥ 16.0.0, < 16.2.1 ∪ ≥ 17.0.0, < 18.3.3 ∪ ≥ 18.4.0, < 18.6.0
Update to 15.3.2; Update to 16.2.1; Update to 18.3.3; Update to 18.6.0
horizon Ubuntu:16.04:LTS
- Versions
- 2:8.0.0-0ubuntu2
- 2:9.0.0~b1-0ubuntu1
- 2:9.0.0~b1-0ubuntu2
- 2:9.0.0~b2-0ubuntu1
- 2:9.0.0~b3-0ubuntu1
- 2:9.0.0~rc1-0ubuntu1
- 2:9.0.0-0ubuntu1
- 2:9.0.0-0ubuntu2
- 2:9.0.0-0ubuntu2.16.04.1
- 2:9.0.1-0ubuntu2
- 2:9.1.0-0ubuntu1
- 2:9.1.1-0ubuntu1
- 2:9.1.2-0ubuntu1
- 2:9.1.2-0ubuntu2
- 2:9.1.2-0ubuntu3
- 2:9.1.2-0ubuntu5
- Affected ranges
- ECOSYSTEM: < 2:9.1.2-0ubuntu5.2
Update to 2:9.1.2-0ubuntu5.2
horizon Ubuntu:18.04:LTS
- Versions
- 3:12.0.0-0ubuntu2.1
- 3:12.0.0-0ubuntu3
- 3:13.0.0~b1-0ubuntu1
- 3:13.0.0~b1-0ubuntu2
- 3:13.0.0-0ubuntu1
- 3:13.0.0-0ubuntu1.1
- 3:13.0.1-0ubuntu1
- 3:13.0.1-0ubuntu2
- 3:13.0.1-0ubuntu3
- 3:13.0.1-0ubuntu4
- 3:13.0.1-0ubuntu5
- 3:13.0.1-0ubuntu6
- 3:13.0.2-0ubuntu1
- 3:13.0.2-0ubuntu2
- 3:13.0.2-0ubuntu3
- 3:13.0.3-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 3:13.0.3-0ubuntu2
Update to 3:13.0.3-0ubuntu2
horizon Ubuntu:20.04:LTS
- Versions
- 3:16.0.0-0ubuntu1
- 3:17.0.0~b1~git2019121712.f7313b74c-0ubuntu1
- 3:18.0.1~git2020021409.bb959361b-0ubuntu2
- 3:18.0.1~git2020021409.bb959361b-0ubuntu3
- 3:18.2.1~git2020032709.2c4470272-0ubuntu1
- 3:18.2.1~git2020041013.754804667-0ubuntu1
- 3:18.2.1~git2020041013.754804667-0ubuntu2
- 3:18.2.1~git2020041013.754804667-0ubuntu3
- 3:18.3.2-0ubuntu0.20.04.1
- 3:18.3.2-0ubuntu0.20.04.2
- Affected ranges
- ECOSYSTEM: < 3:18.3.2-0ubuntu0.20.04.4
Update to 3:18.3.2-0ubuntu0.20.04.4
Original sources
- https://bugs.launchpad.net/horizon/+bug/1865026
- https://review.opendev.org/c/openstack/horizon/+/758841/
- https://review.opendev.org/c/openstack/horizon/+/758843/
- https://security.openstack.org/ossa/OSSA-2020-008.html
- http://www.openwall.com/lists/oss-security/2020/12/08/2
- https://www.debian.org/security/2020/dsa-4820
- https://nvd.nist.gov/vuln/detail/CVE-2020-29565