p PatchFirst

CVE-2020-29599

CVE-2020-29599

This page contains facts from public vulnerability sources. Check the original advisory before updating.

ImageMagick before 6.9.11-40 and 7.x before 7.0.10-40 mishandles the -authenticate option, which allows setting a password for password-protected PDF files. The user-controlled password was not properly escaped/sanitized and it was therefore possible to inject additional shell commands via coders/pdf.c.

CVSS 7.8 · High · EPSS 7.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • imagemagick Debian:12

    Affected ranges
    • ECOSYSTEM: < 8:6.9.11.57+dfsg-1

    Update to 8:6.9.11.57+dfsg-1

  • imagemagick Debian:13

    Affected ranges
    • ECOSYSTEM: < 8:6.9.11.57+dfsg-1

    Update to 8:6.9.11.57+dfsg-1

  • imagemagick Debian:14

    Affected ranges
    • ECOSYSTEM: < 8:6.9.11.57+dfsg-1

    Update to 8:6.9.11.57+dfsg-1

  • imagemagick Ubuntu:20.04:LTS

    Versions
    • 8:6.9.10.23+dfsg-2.1ubuntu3
    • 8:6.9.10.23+dfsg-2.1ubuntu8
    • 8:6.9.10.23+dfsg-2.1ubuntu9
    • 8:6.9.10.23+dfsg-2.1ubuntu10
    • 8:6.9.10.23+dfsg-2.1ubuntu11
    • 8:6.9.10.23+dfsg-2.1ubuntu11.1
    • 8:6.9.10.23+dfsg-2.1ubuntu11.2
    • 8:6.9.10.23+dfsg-2.1ubuntu11.4
    • 8:6.9.10.23+dfsg-2.1ubuntu11.5
    • 8:6.9.10.23+dfsg-2.1ubuntu11.6
    • 8:6.9.10.23+dfsg-2.1ubuntu11.7
    Affected ranges
    • ECOSYSTEM: < 8:6.9.10.23+dfsg-2.1ubuntu11.9

    Update to 8:6.9.10.23+dfsg-2.1ubuntu11.9

Original sources

Check your server →