CVE-2020-36049
CVE-2020-36049
This page contains facts from public vulnerability sources. Check the original advisory before updating.
socket.io-parser before 3.4.1 allows attackers to cause a denial of service (memory consumption) via a large packet because a concatenation approach is used.
CVSS 7.5 · High · EPSS 2.7% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-socket.io-parser Debian:12
- Affected ranges
- ECOSYSTEM: < 3.4.1-1
Update to 3.4.1-1
node-socket.io-parser Debian:13
- Affected ranges
- ECOSYSTEM: < 3.4.1-1
Update to 3.4.1-1
node-socket.io-parser Debian:14
- Affected ranges
- ECOSYSTEM: < 3.4.1-1
Update to 3.4.1-1
socket.io-parser npm
- Affected ranges
- SEMVER: < 3.3.2
Update to 3.3.2
socket.io-parser npm
- Versions
- 3.4.0
- Affected ranges
- SEMVER: ≥ 3.4.0, < 3.4.1
Update to 3.4.1
node-socket.io-parser Ubuntu:18.04:LTS
- Versions
- 2.3.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-socket.io-parser Ubuntu:20.04:LTS
- Versions
- 3.3.0-1
- 3.4.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-socket.io-parser Ubuntu:22.04:LTS
- Versions
- 4.0.2-1
- 4.1.1+~3.0.0-1
- 4.1.2+~3.0.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-socket.io-parser Ubuntu:24.04:LTS
- Versions
- 4.2.1+~3.1.0-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-socket.io-parser Ubuntu:25.10
- Versions
- 4.2.1+~3.1.0-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-socket.io-parser Ubuntu:26.10
- Versions
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-socket.io-parser Ubuntu:26.04:LTS
- Versions
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published