p PatchFirst

CVE-2020-36327

CVE-2020-36327

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every "Dependency Confusion" issue in every product.

CVSS 8.8 · High · EPSS 6.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rubygems Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.3.5-1

    Update to 3.3.5-1

  • rubygems Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.3.5-1

    Update to 3.3.5-1

  • rubygems Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.3.5-1

    Update to 3.3.5-1

  • bundler Ubuntu:16.04:LTS

    Versions
    • 1.10.6-1
    • 1.10.6-2
    • 1.11.2-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • bundler Ubuntu:Pro:18.04:LTS

    Versions
    • 1.15.1-1
    • 1.16.1-1
    • 1.16.1-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • bundler Ubuntu:20.04:LTS

    Versions
    • 1.17.3-3
    • 2.1.4-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →