CVE-2020-5301
CVE-2020-5301 · Information disclosure of source code in SimpleSAMLphp
This page contains facts from public vulnerability sources. Check the original advisory before updating.
SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. The module controller in `SimpleSAML\Module` that processes requests for pages hosted by modules, has code to identify paths ending with `.php` and process those as PHP code. If no other suitable way of handling the given path exists it presents the file to the browser. The check to identify paths ending with `.php` does not account for uppercase letters. If someone requests a path ending with e.g. `.PHP` and the server is serving the code from a case-insensitive file system, such as on Windows, the processing of the PHP code does not occur, and the source code is instead presented to the browser. An attacker may use this issue to gain access to the source code in third-party modules that is meant to be private, or even sensitive. However, the attack surface is considered small, as the attack will only work when SimpleSAMLphp serves such content from a file system that is not case-sensitive, such as on Windows. This issue is fixed in version 1.18.6.
CVSS 3.0 · Low · EPSS 0.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
simplesamlphp
- Versions
- < 1.18.6: Affected
No fix published
simplesamlphp/simplesamlphp Packagist
- Versions
- 1.16.0
- 1.16.0-rc1
- 1.16.1
- 1.16.2
- 1.16.3
- v1.12.0
- v1.13.0
- v1.13.0-rc1
- v1.13.0-rc2
- v1.13.1
- v1.13.2
- v1.14.0
- v1.14.0-rc1
- v1.14.1
- v1.14.10
- v1.14.11
- v1.14.12
- v1.14.13
- v1.14.14
- v1.14.15
- v1.14.16
- v1.14.17
- v1.14.2
- v1.14.3
- v1.14.4
- v1.14.5
- v1.14.6
- v1.14.7
- v1.14.8
- v1.14.9
- v1.15.0
- v1.15.0-rc1
- v1.15.0-rc2
- v1.15.0-rc3
- v1.15.1
- v1.15.2
- v1.15.3
- v1.15.4
- v1.17.0
- v1.17.0-rc1
- v1.17.0-rc2
- v1.17.0-rc3
- v1.17.1
- v1.17.2
- v1.17.3
- v1.17.4
- v1.17.5
- v1.17.6
- v1.17.7
- v1.17.8
- v1.18.0
- v1.18.0-rc1
- v1.18.0-rc2
- v1.18.1
- v1.18.2
- v1.18.3
- v1.18.4
- v1.18.5
- Affected ranges
- ECOSYSTEM: < 1.18.6
Update to 1.18.6