CVE-2020-7059
CVE-2020-7059 · OOB read in php_strip_tags_ex
This page contains facts from public vulnerability sources. Check the original advisory before updating.
When using fgetss() function to read data with stripping tags, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause this function to read past the allocated buffer. This may lead to information disclosure or crash.
CVSS 6.5 · Medium · EPSS 7.4% · Fix available
- Published
- Updated
Affected products and versions
php
- Versions
- ≥ 7.2.x, < 7.2.27: Affected (custom)
- ≥ 7.3.x, < 7.3.14: Affected (custom)
- ≥ 7.4.x, < 7.4.2: Affected (custom)
Update to 7.2.27; Update to 7.3.14; Update to 7.4.2
php7.4 Debian:11
- Affected ranges
- ECOSYSTEM: < 7.4.2-7
Update to 7.4.2-7
php5 Ubuntu:Pro:14.04:LTS
- Versions
- 5.5.3+dfsg-1ubuntu2
- 5.5.3+dfsg-1ubuntu3
- 5.5.6+dfsg-1ubuntu1
- 5.5.6+dfsg-1ubuntu2
- 5.5.8+dfsg-2ubuntu1
- 5.5.9+dfsg-1ubuntu1
- 5.5.9+dfsg-1ubuntu2
- 5.5.9+dfsg-1ubuntu3
- 5.5.9+dfsg-1ubuntu4
- 5.5.9+dfsg-1ubuntu4.1
- 5.5.9+dfsg-1ubuntu4.2
- 5.5.9+dfsg-1ubuntu4.3
- 5.5.9+dfsg-1ubuntu4.4
- 5.5.9+dfsg-1ubuntu4.5
- 5.5.9+dfsg-1ubuntu4.6
- 5.5.9+dfsg-1ubuntu4.7
- 5.5.9+dfsg-1ubuntu4.9
- 5.5.9+dfsg-1ubuntu4.11
- 5.5.9+dfsg-1ubuntu4.12
- 5.5.9+dfsg-1ubuntu4.13
- 5.5.9+dfsg-1ubuntu4.14
- 5.5.9+dfsg-1ubuntu4.16
- 5.5.9+dfsg-1ubuntu4.17
- 5.5.9+dfsg-1ubuntu4.19
- 5.5.9+dfsg-1ubuntu4.20
- 5.5.9+dfsg-1ubuntu4.21
- 5.5.9+dfsg-1ubuntu4.22
- 5.5.9+dfsg-1ubuntu4.23
- 5.5.9+dfsg-1ubuntu4.24
- 5.5.9+dfsg-1ubuntu4.25
- 5.5.9+dfsg-1ubuntu4.26
- 5.5.9+dfsg-1ubuntu4.27
- 5.5.9+dfsg-1ubuntu4.29
- 5.5.9+dfsg-1ubuntu4.29+esm1
- 5.5.9+dfsg-1ubuntu4.29+esm2
- 5.5.9+dfsg-1ubuntu4.29+esm3
- 5.5.9+dfsg-1ubuntu4.29+esm4
- 5.5.9+dfsg-1ubuntu4.29+esm5
- 5.5.9+dfsg-1ubuntu4.29+esm6
- 5.5.9+dfsg-1ubuntu4.29+esm8
- Affected ranges
- ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.29+esm10
Update to 5.5.9+dfsg-1ubuntu4.29+esm10
php7.0 Ubuntu:16.04:LTS
- Versions
- 7.0.1-5
- 7.0.1-6
- 7.0.2-1
- 7.0.2-3
- 7.0.2-4
- 7.0.2-5
- 7.0.3-2
- 7.0.3-3
- 7.0.3-9ubuntu1
- 7.0.4-5ubuntu1
- 7.0.4-5ubuntu2
- 7.0.4-7ubuntu1
- 7.0.4-7ubuntu2
- 7.0.4-7ubuntu2.1
- 7.0.8-0ubuntu0.16.04.1
- 7.0.8-0ubuntu0.16.04.2
- 7.0.8-0ubuntu0.16.04.3
- 7.0.13-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.2
- 7.0.15-0ubuntu0.16.04.4
- 7.0.18-0ubuntu0.16.04.1
- 7.0.22-0ubuntu0.16.04.1
- 7.0.25-0ubuntu0.16.04.1
- 7.0.28-0ubuntu0.16.04.1
- 7.0.30-0ubuntu0.16.04.1
- 7.0.32-0ubuntu0.16.04.1
- 7.0.33-0ubuntu0.16.04.1
- 7.0.33-0ubuntu0.16.04.2
- 7.0.33-0ubuntu0.16.04.3
- 7.0.33-0ubuntu0.16.04.4
- 7.0.33-0ubuntu0.16.04.5
- 7.0.33-0ubuntu0.16.04.6
- 7.0.33-0ubuntu0.16.04.7
- 7.0.33-0ubuntu0.16.04.9
- Affected ranges
- ECOSYSTEM: < 7.0.33-0ubuntu0.16.04.11
Update to 7.0.33-0ubuntu0.16.04.11
php7.2 Ubuntu:18.04:LTS
- Versions
- 7.2.1-1ubuntu2
- 7.2.2-1ubuntu1
- 7.2.2-1ubuntu2
- 7.2.3-1ubuntu1
- 7.2.5-0ubuntu0.18.04.1
- 7.2.7-0ubuntu0.18.04.1
- 7.2.7-0ubuntu0.18.04.2
- 7.2.10-0ubuntu0.18.04.1
- 7.2.15-0ubuntu0.18.04.1
- 7.2.15-0ubuntu0.18.04.2
- 7.2.17-0ubuntu0.18.04.1
- 7.2.19-0ubuntu0.18.04.1
- 7.2.19-0ubuntu0.18.04.2
- 7.2.24-0ubuntu0.18.04.1
- 7.2.24-0ubuntu0.18.04.2
- Affected ranges
- ECOSYSTEM: < 7.2.24-0ubuntu0.18.04.3
Update to 7.2.24-0ubuntu0.18.04.3
Original sources
- https://seclists.org/bugtraq/2020/Feb/27
- https://www.debian.org/security/2020/dsa-4626
- https://usn.ubuntu.com/4279-1/
- https://www.debian.org/security/2020/dsa-4628
- https://seclists.org/bugtraq/2020/Feb/31
- https://lists.debian.org/debian-lts-announce/2020/02/msg00030.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html
- https://security.gentoo.org/glsa/202003-57
- https://www.oracle.com/security-alerts/cpujul2020.html
- https://bugs.php.net/bug.php?id=79099
- https://security.netapp.com/advisory/ntap-20200221-0002/
- https://seclists.org/bugtraq/2021/Jan/3
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.tenable.com/security/tns-2021-14
- https://nvd.nist.gov/vuln/detail/CVE-2020-7059