p PatchFirst

CVE-2020-7928

CVE-2020-7928 · Improper neutralization of null byte leads to read overrun

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A user authorized to perform database queries may trigger a read overrun and access arbitrary memory by issuing specially crafted queries. This issue affects MongoDB Server v4.4 versions prior to 4.4.1; MongoDB Server v4.2 versions prior to 4.2.9; MongoDB Server v4.0 versions prior to 4.0.20 and MongoDB Server v3.6 versions prior to 3.6.20.

CVSS 6.5 · Medium · EPSS 1.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • mongodb server

    Versions
    • ≥ 4.4, < 4.4.1: Affected (custom)
    • ≥ 4.2, < 4.2.9: Affected (custom)
    • ≥ 4.0, < 4.0.20: Affected (custom)
    • ≥ 3.6, < 3.6.20: Affected (custom)

    Update to 3.6.20; Update to 4.0.20; Update to 4.2.9; Update to 4.4.1

  • mongodb Ubuntu:Pro:18.04:LTS

    Versions
    • 1:3.4.7-1
    • 1:3.4.7-1ubuntu1
    • 1:3.4.7-1ubuntu2
    • 1:3.4.7-1ubuntu4
    • 1:3.4.14-3ubuntu1
    • 1:3.4.14-3ubuntu2
    • 1:3.6.3-0ubuntu1
    • 1:3.6.3-0ubuntu1.1
    • 1:3.6.3-0ubuntu1.3
    • 1:3.6.3-0ubuntu1.4
    • 1:3.6.3-0ubuntu1.4+esm1
    • 1:3.6.3-0ubuntu1.4+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:20.04:LTS

    Versions
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →