p PatchFirst

CVE-2020-8251

CVE-2020-8251

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

EPSS 8.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • node.js

    Versions
    • ≥ 4.0, < 4.*: Affected (semver)
    • ≥ 5.0, < 5.*: Affected (semver)
    • ≥ 6.0, < 6.*: Affected (semver)
    • ≥ 7.0, < 7.*: Affected (semver)
    • ≥ 8.0, < 8.*: Affected (semver)
    • ≥ 9.0, < 9.*: Affected (semver)
    • ≥ 11.0, < 11.*: Affected (semver)
    • ≥ 13.0, < 13.*: Affected (semver)
    • ≥ 14.0, < 14.11.0: Affected (semver)

    Update to 14.11.0

Original sources

Check your server →