p PatchFirst

CVE-2020-9281

CVE-2020-9281

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor 4.0 before 4.14 allows remote attackers to inject arbitrary web script through a crafted "protected" comment (with the cke_protected syntax).

CVSS 6.1 · Medium · EPSS 4.3% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ckeditor4 npm

    Affected ranges
    • SEMVER: < 4.14.0

    Update to 4.14.0

  • ckeditor Ubuntu:Pro:16.04:LTS

    Versions
    • 4.4.4+dfsg1-3
    • 4.5.6+dfsg-1
    • 4.5.7+dfsg-1
    • 4.5.7+dfsg-2
    Affected ranges
    • ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.16.04.1~esm1

    Update to 4.5.7+dfsg-2ubuntu0.16.04.1~esm1

  • ckeditor Ubuntu:18.04:LTS

    Versions
    • 4.5.7+dfsg-2
    Affected ranges
    • ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.18.04.1

    Update to 4.5.7+dfsg-2ubuntu0.18.04.1

  • ckeditor Ubuntu:20.04:LTS

    Versions
    • 4.11.1+dfsg-1
    • 4.12.1+dfsg-1
    Affected ranges
    • ECOSYSTEM: < 4.12.1+dfsg-1ubuntu0.1

    Update to 4.12.1+dfsg-1ubuntu0.1

Original sources

Check your server →