CVE-2021-20183
CVE-2021-20183
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.
CVSS 5.4 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- moodle 3.10.1: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.10.0
- v3.10.0-beta
- v3.10.0-rc1
- v3.10.0-rc2
- v3.10.1
- v3.10.10
- v3.10.11
- v3.10.2
- v3.10.3
- v3.10.4
- v3.10.5
- v3.10.6
- v3.10.7
- v3.10.8
- v3.10.9
- v3.11.0
- v3.11.0-beta
- v3.11.0-rc1
- v3.11.0-rc2
- v3.11.1
- v3.11.10
- v3.11.11
- v3.11.12
- v3.11.13
- v3.11.14
- v3.11.15
- v3.11.16
- v3.11.17
- v3.11.18
- v3.11.2
- v3.11.3
- v3.11.4
- v3.11.5
- v3.11.6
- v3.11.7
- v3.11.8
- v3.11.9
- Affected ranges
- ECOSYSTEM: ≥ 3.10, < 4.0.0-beta
Update to 4.0.0-beta
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published