CVE-2021-20184
CVE-2021-20184
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.
CVSS 4.3 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- moodle 3.10.1, moodle 3.9.4, moodle 3.8.7: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.8.0
- v3.8.0-beta
- v3.8.0-rc1
- v3.8.1
- v3.8.2
- v3.8.3
- v3.8.4
- v3.8.5
- v3.8.6
- Affected ranges
- ECOSYSTEM: ≥ 3.8, < 3.8.7
Update to 3.8.7
moodle/moodle Packagist
- Versions
- v3.9.0
- v3.9.0-beta
- v3.9.0-rc1
- v3.9.0-rc2
- v3.9.0-rc3
- v3.9.1
- v3.9.2
- v3.9.3
- Affected ranges
- ECOSYSTEM: ≥ 3.9, < 3.9.4
Update to 3.9.4
moodle/moodle Packagist
- Versions
- v3.10.0
- v3.10.0-beta
- v3.10.0-rc1
- v3.10.0-rc2
- Affected ranges
- ECOSYSTEM: ≥ 3.10, < 3.10.1
Update to 3.10.1
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published