p PatchFirst

CVE-2021-20270

CVE-2021-20270

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An infinite loop in SMLLexer in Pygments versions 1.5 to 2.7.3 may lead to denial of service when performing syntax highlighting of a Standard ML (SML) source file, as demonstrated by input that only contains the "exception" keyword.

CVSS 8.7 · High · EPSS 2.8% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • python-pygments

    Versions
    • python-pygments 2.7.4: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.35.2-1

    Update to 1:1.35.2-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.35.2-1

    Update to 1:1.35.2-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.35.2-1

    Update to 1:1.35.2-1

  • pygments Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.7.1+dfsg-2

    Update to 2.7.1+dfsg-2

  • pygments Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.7.1+dfsg-2

    Update to 2.7.1+dfsg-2

  • pygments Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.7.1+dfsg-2

    Update to 2.7.1+dfsg-2

  • pygments PyPI

    Versions
    • 1.5
    • 1.6
    • 1.6rc1
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0rc1
    • 2.1
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.2.0
    • 2.3.0
    • 2.3.1
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.5.1
    • 2.5.2
    • 2.6.0
    • 2.6.1
    • 2.7.0
    • 2.7.1
    • 2.7.2
    • 2.7.3
    Affected ranges
    • ECOSYSTEM: ≥ 1.5, < 2.7.4

    Update to 2.7.4

  • pygments Ubuntu:Pro:14.04:LTS

    Versions
    • 1.6+dfsg-1
    • 1.6+dfsg-1build1
    • 1.6+dfsg-1ubuntu1
    • 1.6+dfsg-1ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 1.6+dfsg-1ubuntu1.1+esm1

    Update to 1.6+dfsg-1ubuntu1.1+esm1

  • pygments Ubuntu:16.04:LTS

    Versions
    • 2.0.1+dfsg-1.1svn1
    • 2.0.1+dfsg-1.1ubuntu1
    • 2.1+dfsg-1
    Affected ranges
    • ECOSYSTEM: < 2.1+dfsg-1ubuntu0.1

    Update to 2.1+dfsg-1ubuntu0.1

  • pygments Ubuntu:18.04:LTS

    Versions
    • 2.2.0+dfsg-1
    Affected ranges
    • ECOSYSTEM: < 2.2.0+dfsg-1ubuntu0.1

    Update to 2.2.0+dfsg-1ubuntu0.1

  • pygments Ubuntu:20.04:LTS

    Versions
    • 2.3.1+dfsg-1ubuntu1
    • 2.3.1+dfsg-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 2.3.1+dfsg-1ubuntu2.1

    Update to 2.3.1+dfsg-1ubuntu2.1

Original sources

Check your server →