CVE-2021-21358
CVE-2021-21358 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in typo3/cms-form
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 10.4.14, 11.1.1 it has been discovered that the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. This is fixed in versions 10.4.14, 11.1.1.
CVSS 5.4 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
typo3.cms
- Versions
- >= 10.2.0, <= 10.4.13: Affected
- >= 11.0.0, <= 11.1.0: Affected
No fix published
typo3/cms-form Packagist
- Versions
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Affected ranges
- ECOSYSTEM: ≥ 10.2.0, < 10.4.14
Update to 10.4.14
typo3/cms-form Packagist
- Versions
- v11.0.0
- v11.1.0
- Affected ranges
- ECOSYSTEM: ≥ 11.0.0, < 11.1.1
Update to 11.1.1
typo3/cms-core Packagist
- Versions
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Affected ranges
- ECOSYSTEM: ≥ 10.0.0, < 10.4.14
Update to 10.4.14
typo3/cms-core Packagist
- Versions
- v11.0.0
- v11.1.0
- Affected ranges
- ECOSYSTEM: ≥ 11.0.0, < 11.1.1
Update to 11.1.1
typo3/cms Packagist
- Versions
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.10
- v10.4.11
- v10.4.12
- v10.4.13
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- v10.4.6
- v10.4.7
- v10.4.8
- v10.4.9
- Affected ranges
- ECOSYSTEM: ≥ 10.0.0, < 10.4.14
Update to 10.4.14
typo3/cms Packagist
- Versions
- v11.0.0
- v11.1.0
- Affected ranges
- ECOSYSTEM: ≥ 11.0.0, < 11.1.1
Update to 11.1.1