CVE-2021-21366
CVE-2021-21366 · Misinterpretation of malicious XML input
This page contains facts from public vulnerability sources. Check the original advisory before updating.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents. This may lead to unexpected syntactic changes during XML processing in some downstream applications. This is fixed in version 0.5.0. As a workaround downstream applications can validate the input and reject the maliciously crafted documents.
CVSS 4.3 · Medium · EPSS 1.3% · Fix available
- Published
- Updated
Affected products and versions
xmldom
- Versions
- < 0.5.0: Affected
No fix published
node-xmldom Debian:12
- Affected ranges
- ECOSYSTEM: < 0.5.0-1
Update to 0.5.0-1
node-xmldom Debian:13
- Affected ranges
- ECOSYSTEM: < 0.5.0-1
Update to 0.5.0-1
node-xmldom Debian:14
- Affected ranges
- ECOSYSTEM: < 0.5.0-1
Update to 0.5.0-1
xmldom npm
- Affected ranges
- SEMVER: < 0.5.0
Update to 0.5.0
node-xmldom Ubuntu:20.04:LTS
- Versions
- 0.1.27+ds-1
- Affected ranges
- ECOSYSTEM: < 0.1.27+ds-1+deb10u2build0.20.04.1
Update to 0.1.27+ds-1+deb10u2build0.20.04.1
Original sources
- https://github.com/xmldom/xmldom/security/advisories/GHSA-h6q6-9hqw-rwfv
- https://www.npmjs.com/package/xmldom
- https://github.com/xmldom/xmldom/releases/tag/0.5.0
- https://github.com/xmldom/xmldom/commit/d4201b9dfbf760049f457f9f08a3888d48835135
- https://lists.debian.org/debian-lts-announce/2023/01/msg00000.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-21366