CVE-2021-21705
CVE-2021-21705 · Incorrect URL validation in FILTER_VALIDATE_URL
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.
CVSS 4.3 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Affected products and versions
php
- Versions
- ≥ 7.3.x, < 7.3.29: Affected (custom)
- ≥ 7.4.x, < 7.4.21: Affected (custom)
- ≥ 8.0.X, < 8.0.8: Affected (custom)
Update to 7.3.29; Update to 7.4.21; Update to 8.0.8
php7.4 Debian:11
- Affected ranges
- ECOSYSTEM: < 7.4.21-1+deb11u1
Update to 7.4.21-1+deb11u1
php5 Ubuntu:Pro:14.04:LTS
- Versions
- 5.5.3+dfsg-1ubuntu2
- 5.5.3+dfsg-1ubuntu3
- 5.5.6+dfsg-1ubuntu1
- 5.5.6+dfsg-1ubuntu2
- 5.5.8+dfsg-2ubuntu1
- 5.5.9+dfsg-1ubuntu1
- 5.5.9+dfsg-1ubuntu2
- 5.5.9+dfsg-1ubuntu3
- 5.5.9+dfsg-1ubuntu4
- 5.5.9+dfsg-1ubuntu4.1
- 5.5.9+dfsg-1ubuntu4.2
- 5.5.9+dfsg-1ubuntu4.3
- 5.5.9+dfsg-1ubuntu4.4
- 5.5.9+dfsg-1ubuntu4.5
- 5.5.9+dfsg-1ubuntu4.6
- 5.5.9+dfsg-1ubuntu4.7
- 5.5.9+dfsg-1ubuntu4.9
- 5.5.9+dfsg-1ubuntu4.11
- 5.5.9+dfsg-1ubuntu4.12
- 5.5.9+dfsg-1ubuntu4.13
- 5.5.9+dfsg-1ubuntu4.14
- 5.5.9+dfsg-1ubuntu4.16
- 5.5.9+dfsg-1ubuntu4.17
- 5.5.9+dfsg-1ubuntu4.19
- 5.5.9+dfsg-1ubuntu4.20
- 5.5.9+dfsg-1ubuntu4.21
- 5.5.9+dfsg-1ubuntu4.22
- 5.5.9+dfsg-1ubuntu4.23
- 5.5.9+dfsg-1ubuntu4.24
- 5.5.9+dfsg-1ubuntu4.25
- 5.5.9+dfsg-1ubuntu4.26
- 5.5.9+dfsg-1ubuntu4.27
- 5.5.9+dfsg-1ubuntu4.29
- 5.5.9+dfsg-1ubuntu4.29+esm1
- 5.5.9+dfsg-1ubuntu4.29+esm2
- 5.5.9+dfsg-1ubuntu4.29+esm3
- 5.5.9+dfsg-1ubuntu4.29+esm4
- 5.5.9+dfsg-1ubuntu4.29+esm5
- 5.5.9+dfsg-1ubuntu4.29+esm6
- 5.5.9+dfsg-1ubuntu4.29+esm8
- 5.5.9+dfsg-1ubuntu4.29+esm10
- 5.5.9+dfsg-1ubuntu4.29+esm11
- 5.5.9+dfsg-1ubuntu4.29+esm12
- 5.5.9+dfsg-1ubuntu4.29+esm13
- Affected ranges
- ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.29+esm14
Update to 5.5.9+dfsg-1ubuntu4.29+esm14
php7.0 Ubuntu:Pro:16.04:LTS
- Versions
- 7.0.1-5
- 7.0.1-6
- 7.0.2-1
- 7.0.2-3
- 7.0.2-4
- 7.0.2-5
- 7.0.3-2
- 7.0.3-3
- 7.0.3-9ubuntu1
- 7.0.4-5ubuntu1
- 7.0.4-5ubuntu2
- 7.0.4-7ubuntu1
- 7.0.4-7ubuntu2
- 7.0.4-7ubuntu2.1
- 7.0.8-0ubuntu0.16.04.1
- 7.0.8-0ubuntu0.16.04.2
- 7.0.8-0ubuntu0.16.04.3
- 7.0.13-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.2
- 7.0.15-0ubuntu0.16.04.4
- 7.0.18-0ubuntu0.16.04.1
- 7.0.22-0ubuntu0.16.04.1
- 7.0.25-0ubuntu0.16.04.1
- 7.0.28-0ubuntu0.16.04.1
- 7.0.30-0ubuntu0.16.04.1
- 7.0.32-0ubuntu0.16.04.1
- 7.0.33-0ubuntu0.16.04.1
- 7.0.33-0ubuntu0.16.04.2
- 7.0.33-0ubuntu0.16.04.3
- 7.0.33-0ubuntu0.16.04.4
- 7.0.33-0ubuntu0.16.04.5
- 7.0.33-0ubuntu0.16.04.6
- 7.0.33-0ubuntu0.16.04.7
- 7.0.33-0ubuntu0.16.04.9
- 7.0.33-0ubuntu0.16.04.11
- 7.0.33-0ubuntu0.16.04.12
- 7.0.33-0ubuntu0.16.04.14
- 7.0.33-0ubuntu0.16.04.15
- 7.0.33-0ubuntu0.16.04.16
- Affected ranges
- ECOSYSTEM: < 7.0.33-0ubuntu0.16.04.16+esm1
Update to 7.0.33-0ubuntu0.16.04.16+esm1
php7.2 Ubuntu:18.04:LTS
- Versions
- 7.2.1-1ubuntu2
- 7.2.2-1ubuntu1
- 7.2.2-1ubuntu2
- 7.2.3-1ubuntu1
- 7.2.5-0ubuntu0.18.04.1
- 7.2.7-0ubuntu0.18.04.1
- 7.2.7-0ubuntu0.18.04.2
- 7.2.10-0ubuntu0.18.04.1
- 7.2.15-0ubuntu0.18.04.1
- 7.2.15-0ubuntu0.18.04.2
- 7.2.17-0ubuntu0.18.04.1
- 7.2.19-0ubuntu0.18.04.1
- 7.2.19-0ubuntu0.18.04.2
- 7.2.24-0ubuntu0.18.04.1
- 7.2.24-0ubuntu0.18.04.2
- 7.2.24-0ubuntu0.18.04.3
- 7.2.24-0ubuntu0.18.04.4
- 7.2.24-0ubuntu0.18.04.6
- 7.2.24-0ubuntu0.18.04.7
- Affected ranges
- ECOSYSTEM: < 7.2.24-0ubuntu0.18.04.8
Update to 7.2.24-0ubuntu0.18.04.8
php7.4 Ubuntu:20.04:LTS
- Versions
- 7.4.3-4build1
- 7.4.3-4build2
- 7.4.3-4ubuntu1
- 7.4.3-4ubuntu1.1
- 7.4.3-4ubuntu2.2
- 7.4.3-4ubuntu2.4
- Affected ranges
- ECOSYSTEM: < 7.4.3-4ubuntu2.5
Update to 7.4.3-4ubuntu2.5