p PatchFirst

CVE-2021-22890

CVE-2021-22890

This page contains facts from public vulnerability sources. Check the original advisory before updating.

curl 7.63.0 to and including 7.75.0 includes vulnerability that allows a malicious HTTPS proxy to MITM a connection due to bad handling of TLS 1.3 session tickets. When using a HTTPS proxy and TLS 1.3, libcurl can confuse session tickets arriving from the HTTPS proxy but work as if they arrived from the remote server and then wrongly "short-cut" the host handshake. When confusing the tickets, a HTTPS proxy can trick libcurl to use the wrong session ticket resume for the host and thereby circumvent the server TLS certificate check and make a MITM attack to be possible to perform unnoticed. Note that such a malicious HTTPS proxy needs to provide a certificate that curl will accept for the MITMed server for an attack to work - unless curl has been told to ignore the server certificate check.

CVSS 4.3 · Medium · EPSS 3.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • https://github.com/curl/curl

    Versions
    • 7.63.0 to and including 7.75.0: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.74.0-1.2

    Update to 7.74.0-1.2

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.74.0-1.2

    Update to 7.74.0-1.2

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.74.0-1.2

    Update to 7.74.0-1.2

  • curl Ubuntu:20.04:LTS

    Versions
    • 7.65.3-1ubuntu3
    • 7.65.3-1ubuntu4
    • 7.66.0-1ubuntu1
    • 7.67.0-2ubuntu1
    • 7.68.0-1ubuntu1
    • 7.68.0-1ubuntu2
    • 7.68.0-1ubuntu2.1
    • 7.68.0-1ubuntu2.2
    • 7.68.0-1ubuntu2.4
    Affected ranges
    • ECOSYSTEM: < 7.68.0-1ubuntu2.5

    Update to 7.68.0-1ubuntu2.5

Original sources

Check your server →