CVE-2021-22918
CVE-2021-22918
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().
CVSS 5.3 · Medium · EPSS 23.1% · Fix available
- Published
- Updated
Affected products and versions
node.js
- Versions
- ≥ 4.0, < 4.*: Affected (semver)
- ≥ 5.0, < 5.*: Affected (semver)
- ≥ 6.0, < 6.*: Affected (semver)
- ≥ 7.0, < 7.*: Affected (semver)
- ≥ 8.0, < 8.*: Affected (semver)
- ≥ 9.0, < 9.*: Affected (semver)
- ≥ 10.0, < 10.*: Affected (semver)
- ≥ 11.0, < 11.*: Affected (semver)
- ≥ 12.0, < 12.22.2: Affected (semver)
- ≥ 13.0, < 13.*: Affected (semver)
- ≥ 14.0, < 14.17.2: Affected (semver)
- ≥ 15.0, < 15.*: Affected (semver)
- ≥ 16.0, < 16.4.1: Affected (semver)
Update to 12.22.2; Update to 14.17.2; Update to 16.4.1
libuv1 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.40.0-2
Update to 1.40.0-2
libuv1 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.40.0-2
Update to 1.40.0-2
libuv1 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.40.0-2
Update to 1.40.0-2
libuv1 Ubuntu:20.04:LTS
- Versions
- 1.30.1-1
- 1.33.1-2
- 1.33.1-2ubuntu2
- 1.33.1-3ubuntu1
- 1.34.2-1ubuntu1
- 1.34.2-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.34.2-1ubuntu1.3
Update to 1.34.2-1ubuntu1.3
Original sources
- https://hackerone.com/reports/1209681
- https://nodejs.org/en/blog/vulnerability/july-2021-security-releases/
- https://security.netapp.com/advisory/ntap-20210805-0003/
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://security.gentoo.org/glsa/202401-23
- https://nvd.nist.gov/vuln/detail/CVE-2021-22918