p PatchFirst

CVE-2021-22921

CVE-2021-22921

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Node.js before 16.4.1, 14.17.2, and 12.22.2 is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking.

EPSS 7.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • node.js

    Versions
    • ≥ 4.0, < 4.*: Affected (semver)
    • ≥ 5.0, < 5.*: Affected (semver)
    • ≥ 6.0, < 6.*: Affected (semver)
    • ≥ 7.0, < 7.*: Affected (semver)
    • ≥ 8.0, < 8.*: Affected (semver)
    • ≥ 9.0, < 9.*: Affected (semver)
    • ≥ 10.0, < 10.*: Affected (semver)
    • ≥ 11.0, < 11.*: Affected (semver)
    • ≥ 12.0, < 12.22.2: Affected (semver)
    • ≥ 13.0, < 13.*: Affected (semver)
    • ≥ 14.0, < 14.17.2: Affected (semver)
    • ≥ 15.0, < 15.*: Affected (semver)
    • ≥ 16.0, < 16.4.1: Affected (semver)

    Update to 12.22.2; Update to 14.17.2; Update to 16.4.1

Original sources

Check your server →