p PatchFirst

CVE-2021-22931

CVE-2021-22931

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.

EPSS 22.0% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • node.js

    Versions
    • ≥ 4.0, < 4.*: Affected (semver)
    • ≥ 5.0, < 5.*: Affected (semver)
    • ≥ 6.0, < 6.*: Affected (semver)
    • ≥ 7.0, < 7.*: Affected (semver)
    • ≥ 8.0, < 8.*: Affected (semver)
    • ≥ 9.0, < 9.*: Affected (semver)
    • ≥ 10.0, < 10.*: Affected (semver)
    • ≥ 11.0, < 11.*: Affected (semver)
    • ≥ 12.0, < 12.22.5: Affected (semver)
    • ≥ 13.0, < 13.*: Affected (semver)
    • ≥ 14.0, < 14.17.5: Affected (semver)
    • ≥ 15.0, < 15.*: Affected (semver)
    • ≥ 16.0, < 16.6.2: Affected (semver)

    Update to 12.22.5; Update to 14.17.5; Update to 16.6.2

Original sources

Check your server →