p PatchFirst

CVE-2021-23392

CVE-2021-23392 · Regular Expression Denial of Service (ReDoS)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.

CVSS 5.3 · Medium · EPSS 1.9% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • locutus

    Versions
    • ≥ unspecified, < 2.0.15: Affected (custom)

    Update to 2.0.15

  • locutus npm

    Affected ranges
    • SEMVER: < 2.0.15

    Update to 2.0.15

Original sources

Check your server →