CVE-2021-23418
CVE-2021-23418 · XML External Entity (XXE) Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
CVSS 6.3 · Medium · EPSS 1.7% · Fix available
- Published
- Updated
Affected products and versions
glances
- Versions
- ≥ unspecified, < 3.2.1: Affected (custom)
Update to 3.2.1
glances Debian:12
- Affected ranges
- ECOSYSTEM: < 3.2.3.1+dfsg-1
Update to 3.2.3.1+dfsg-1
glances Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.3.1+dfsg-1
Update to 3.2.3.1+dfsg-1
glances Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.3.1+dfsg-1
Update to 3.2.3.1+dfsg-1
glances PyPI
- Versions
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.4
- 1.4.1
- 1.4.1.1
- 1.4.2
- 1.4.2.1
- 1.5
- 1.5.1
- 1.5.2
- 1.6
- 1.6.1
- 1.7
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 2.0
- 2.0.1
- 2.1
- 2.1.1
- 2.1.2
- 2.10
- 2.11
- 2.11.1
- 2.2
- 2.2.1
- 2.3
- 2.4
- 2.4.1
- 2.4.2
- 2.5
- 2.5.1
- 2.6
- 2.6.1
- 2.6.2
- 2.7
- 2.7.1
- 2.8
- 2.8.1
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.9.0
- 2.9.1
- 3.0
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.4.1
- 3.1.5
- 3.1.6
- 3.1.6.1
- 3.1.6.2
- 3.1.7
- 3.2.0
- Affected ranges
- ECOSYSTEM: < 3.2.1
Update to 3.2.1
glances PyPI
- Versions
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.4
- 1.4.1
- 1.4.1.1
- 1.4.2
- 1.4.2.1
- 1.5
- 1.5.1
- 1.5.2
- 1.6
- 1.6.1
- 1.7
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 2.0
- 2.0.1
- 2.1
- 2.1.1
- 2.1.2
- 2.10
- 2.11
- 2.11.1
- 2.2
- 2.2.1
- 2.3
- 2.4
- 2.4.1
- 2.4.2
- 2.5
- 2.5.1
- 2.6
- 2.6.1
- 2.6.2
- 2.7
- 2.7.1
- 2.8
- 2.8.1
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.9.0
- 2.9.1
- 3.0
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.4.1
- 3.1.5
- 3.1.6
- 3.1.6.1
- 3.1.6.2
- 3.1.7
- 3.2.0
- Affected ranges
- {"events": [{"introduced": "0"}, {"fixed": "85d5a6b4af31fcf785d5a61086cbbd166b40b07a"}, {"fixed": "9d6051be4a42f692392049fdbfc85d5dfa458b32"}, {"fixed": "4b87e979afdc06d98ed1b48da31e69eaa3a9fb94"}], "repo": "https://github.com/nicolargo/glances", "type": "GIT"}
- ECOSYSTEM: < 3.2.1
Update to 3.2.1
glances Ubuntu:Pro:16.04:LTS
- Versions
- 2.3-1build1
- Affected ranges
- ECOSYSTEM: < 2.3-1ubuntu0.1~esm1
Update to 2.3-1ubuntu0.1~esm1
glances Ubuntu:Pro:18.04:LTS
- Versions
- 2.10-2
- 2.11.1-1
- 2.11.1-2
- 2.11.1-3
- Affected ranges
- ECOSYSTEM: < 2.11.1-3ubuntu0.1~esm1
Update to 2.11.1-3ubuntu0.1~esm1
glances Ubuntu:Pro:20.04:LTS
- Versions
- 3.1.0-1
- 3.1.1-1
- 3.1.3-1
- Affected ranges
- ECOSYSTEM: < 3.1.3-1ubuntu0.1~esm1
Update to 3.1.3-1ubuntu0.1~esm1
Original sources
- https://snyk.io/vuln/SNYK-PYTHON-GLANCES-1311807
- https://github.com/nicolargo/glances/commit/4b87e979afdc06d98ed1b48da31e69eaa3a9fb94
- https://github.com/nicolargo/glances/commit/85d5a6b4af31fcf785d5a61086cbbd166b40b07a
- https://github.com/nicolargo/glances/issues/1025
- https://github.com/nicolargo/glances/commit/9d6051be4a42f692392049fdbfc85d5dfa458b32
- https://nvd.nist.gov/vuln/detail/CVE-2021-23418