CVE-2021-23437
CVE-2021-23437 · Regular Expression Denial of Service (ReDoS)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.
CVSS 7.5 · High · EPSS 3.2% · Fix available
- Published
- Updated
Affected products and versions
pillow
- Versions
- ≥ 0, < unspecified: Affected (custom)
- ≥ unspecified, < 8.3.2: Affected (custom)
Update to 8.3.2
pillow Debian:12
- Affected ranges
- ECOSYSTEM: < 8.3.2-1
Update to 8.3.2-1
pillow Debian:13
- Affected ranges
- ECOSYSTEM: < 8.3.2-1
Update to 8.3.2-1
pillow Debian:14
- Affected ranges
- ECOSYSTEM: < 8.3.2-1
Update to 8.3.2-1
pillow PyPI
- Versions
- 5.2.0
- 5.3.0
- 5.4.0
- 5.4.0.dev0
- 5.4.1
- 6.0.0
- 6.1.0
- 6.2.0
- 6.2.1
- 6.2.2
- 7.0.0
- 7.1.0
- 7.1.1
- 7.1.2
- 7.2.0
- 8.0.0
- 8.0.1
- 8.1.0
- 8.1.1
- 8.1.2
- 8.2.0
- 8.3.0
- 8.3.1
- Affected ranges
- ECOSYSTEM: ≥ 5.2.0, < 8.3.2
Update to 8.3.2
pillow PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.3
- 1.4
- 1.5
- 1.6
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 1.7.8
- 2.0.0
- 2.1.0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.7.0
- 2.8.0
- 2.8.1
- 2.8.2
- 2.9.0
- 3.0.0
- 3.1.0
- 3.1.0.rc1
- 3.1.0rc1
- 3.1.1
- 3.1.2
- 3.2.0
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.4.0
- 3.4.1
- 3.4.2
- 4.0.0
- 4.1.0
- 4.1.1
- 4.2.0
- 4.2.1
- 4.3.0
- 5.0.0
- 5.1.0
- 5.2.0
- 5.3.0
- 5.4.0
- 5.4.0.dev0
- 5.4.1
- 6.0.0
- 6.1.0
- 6.2.0
- 6.2.1
- 6.2.2
- 7.0.0
- 7.1.0
- 7.1.1
- 7.1.2
- 7.2.0
- 8.0.0
- 8.0.1
- 8.1.0
- 8.1.1
- 8.1.2
- 8.2.0
- 8.3.0
- 8.3.1
- Affected ranges
- GIT: < 9e08eb8f78fdfd2f476e1b20b7cf38683754866b
- ECOSYSTEM: < 8.3.2
Update to 8.3.2
pillow Ubuntu:Pro:14.04:LTS
- Versions
- 2.2.1-1ubuntu2
- 2.2.1-2ubuntu1
- 2.2.1-3ubuntu2
- 2.2.1-3ubuntu3
- 2.2.1-3ubuntu4
- 2.2.1-3ubuntu6
- 2.3.0-1ubuntu1
- 2.3.0-1ubuntu2
- 2.3.0-1ubuntu3
- 2.3.0-1ubuntu3.2
- 2.3.0-1ubuntu3.3
- 2.3.0-1ubuntu3.4
- 2.3.0-1ubuntu3.4+esm1
- 2.3.0-1ubuntu3.4+esm2
- Affected ranges
- ECOSYSTEM: < 2.3.0-1ubuntu3.4+esm3
Update to 2.3.0-1ubuntu3.4+esm3
pillow Ubuntu:Pro:16.04:LTS
- Versions
- 2.9.0-1
- 3.0.0-1
- 3.0.0-1build1
- 3.1.0-1
- 3.1.1-1
- 3.1.2-0ubuntu1
- 3.1.2-0ubuntu1.1
- 3.1.2-0ubuntu1.3
- 3.1.2-0ubuntu1.4
- 3.1.2-0ubuntu1.5
- 3.1.2-0ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 3.1.2-0ubuntu1.6+esm1
Update to 3.1.2-0ubuntu1.6+esm1
pillow Ubuntu:18.04:LTS
- Versions
- 4.1.1-3build2
- 4.3.0-2ubuntu1
- 5.0.0-1
- 5.1.0-1
- 5.1.0-1ubuntu0.2
- 5.1.0-1ubuntu0.3
- 5.1.0-1ubuntu0.4
- 5.1.0-1ubuntu0.5
- 5.1.0-1ubuntu0.6
- Affected ranges
- ECOSYSTEM: < 5.1.0-1ubuntu0.7
Update to 5.1.0-1ubuntu0.7
pillow Ubuntu:20.04:LTS
- Versions
- 6.1.0-1
- 6.1.0-1build1
- 6.2.1-2
- 7.0.0-4
- 7.0.0-4build1
- 7.0.0-4ubuntu0.1
- 7.0.0-4ubuntu0.2
- 7.0.0-4ubuntu0.3
- 7.0.0-4ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 7.0.0-4ubuntu0.5
Update to 7.0.0-4ubuntu0.5
pillow-python2 Ubuntu:Pro:20.04:LTS
- Versions
- 6.2.1-3~build1
- 6.2.1-3
- 6.2.1-3ubuntu0.1~esm1
- 6.2.1-3ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pillow Ubuntu:22.04:LTS
- Versions
- 8.1.2+dfsg-0.3
- Affected ranges
- ECOSYSTEM: < 9.0.0-1
Update to 9.0.0-1
Original sources
- https://snyk.io/vuln/SNYK-PYTHON-PILLOW-1319443
- https://pillow.readthedocs.io/en/stable/releasenotes/8.3.2.html
- https://github.com/python-pillow/Pillow/commit/9e08eb8f78fdfd2f476e1b20b7cf38683754866b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VKRCL7KKAKOXCVD7M6WC5OKFGL4L3SJT/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RNSG6VFXTAROGF7ACYLMAZNQV4EJ6I2C/
- https://security.gentoo.org/glsa/202211-10
- https://lists.debian.org/debian-lts-announce/2024/03/msg00021.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-23437