p PatchFirst

CVE-2021-25803

CVE-2021-25803

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A buffer overflow vulnerability in the vlc_input_attachment_New component of VideoLAN VLC Media Player 3.0.11 allows attackers to cause an out-of-bounds read via a crafted .avi file.

CVSS 7.1 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • vlc Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.12-1

    Update to 3.0.12-1

  • vlc Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.12-1

    Update to 3.0.12-1

  • vlc Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.12-1

    Update to 3.0.12-1

  • vlc Ubuntu:Pro:16.04:LTS

    Versions
    • 2.2.1-3
    • 2.2.1-5
    • 2.2.2-1
    • 2.2.2-2
    • 2.2.2-3
    • 2.2.2-3build1
    • 2.2.2-4
    • 2.2.2-5
    • 2.2.2-5ubuntu0.16.04.1
    • 2.2.2-5ubuntu0.16.04.2
    • 2.2.2-5ubuntu0.16.04.3
    • 2.2.2-5ubuntu0.16.04.4
    • 2.2.2-5ubuntu0.16.04.5+esm1
    Affected ranges
    • ECOSYSTEM: < 2.2.2-5ubuntu0.16.04.5+esm2

    Update to 2.2.2-5ubuntu0.16.04.5+esm2

  • vlc Ubuntu:Pro:18.04:LTS

    Versions
    • 2.2.6-6
    • 2.2.6-6build1
    • 2.2.7-1
    • 2.2.8-1
    • 2.2.8-1ubuntu4
    • 2.2.8-2
    • 3.0.0~rc1-1ubuntu1
    • 3.0.0~rc1-1ubuntu3
    • 3.0.0~rc2-1ubuntu1
    • 3.0.0~rc2-2ubuntu1
    • 3.0.0~rc2-2ubuntu2
    • 3.0.0~rc4-1ubuntu1
    • 3.0.0~rc7-2ubuntu1
    • 3.0.0~rc8-1ubuntu1
    • 3.0.0-1ubuntu1
    • 3.0.1-1ubuntu5
    • 3.0.1-2ubuntu1
    • 3.0.1-2ubuntu2
    • 3.0.1-3
    • 3.0.1-3build1
    • 3.0.2-0ubuntu0.1
    • 3.0.3-1-1ubuntu1
    • 3.0.4-1ubuntu0.2
    • 3.0.7.1-0ubuntu18.04.1
    • 3.0.8-0ubuntu18.04.1
    Affected ranges
    • ECOSYSTEM: < 3.0.8-0ubuntu18.04.1+esm1

    Update to 3.0.8-0ubuntu18.04.1+esm1

  • vlc Ubuntu:Pro:20.04:LTS

    Versions
    • 3.0.8-2
    • 3.0.8-2build1
    • 3.0.8-3
    • 3.0.8-3build1
    • 3.0.8-3build2
    • 3.0.8-3build4
    • 3.0.8-4
    • 3.0.9.2-1
    Affected ranges
    • ECOSYSTEM: < 3.0.9.2-1ubuntu0.1~esm1

    Update to 3.0.9.2-1ubuntu0.1~esm1

Original sources

Check your server →