p PatchFirst

CVE-2021-25978

CVE-2021-25978 · Apostrophe - XSS

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apostrophe CMS versions between 2.63.0 to 3.3.1 are vulnerable to Stored XSS where an editor uploads an SVG file that contains malicious JavaScript onto the Images module, which triggers XSS once viewed.

CVSS 5.4 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • apostrophe

    Versions
    • ≥ unspecified, ≤ 3.3.1: Affected (custom)
    • ≥ 2.63.0, < unspecified: Affected (custom)

    No fix published

  • apostrophe npm

    Affected ranges
    • SEMVER: ≥ 2.63.0, < 3.4.0

    Update to 3.4.0

Original sources

Check your server →