p PatchFirst

CVE-2021-25979

CVE-2021-25979 · Apostrophe - Insufficient Session Expiration

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apostrophe CMS versions prior to 3.3.1 did not invalidate existing login sessions when disabling a user account or changing the password, creating a situation in which a device compromised by a third party could not be locked out by those means. As a mitigation for older releases the user account in question can be archived (3.x) or moved to the trash (2.x and earlier) which does disable the existing session.

CVSS 9.8 · Critical · EPSS 1.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • apostrophe

    Versions
    • ≥ unspecified, ≤ 3.3.1: Affected (custom)
    • ≥ 2.63.0, < unspecified: Affected (custom)

    No fix published

  • apostrophe npm

    Affected ranges
    • SEMVER: ≥ 2.63.0, < 3.4.0

    Update to 3.4.0

Original sources

Check your server →