CVE-2021-26260
CVE-2021-26260
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR. This is a different flaw from CVE-2021-23215.
CVSS 5.5 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
openexr
- Versions
- OpenEXR 3.0.1: Affected
No fix published
openexr Debian:12
- Affected ranges
- ECOSYSTEM: < 2.5.7-1
Update to 2.5.7-1
openexr Debian:13
- Affected ranges
- ECOSYSTEM: < 2.5.7-1
Update to 2.5.7-1
openexr Debian:14
- Affected ranges
- ECOSYSTEM: < 2.5.7-1
Update to 2.5.7-1
openexr Ubuntu:Pro:16.04:LTS
- Versions
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- 2.2.0-10ubuntu2.1
- 2.2.0-10ubuntu2.2
- 2.2.0-10ubuntu2.3
- 2.2.0-10ubuntu2.4
- 2.2.0-10ubuntu2.6
- Affected ranges
- ECOSYSTEM: < 2.2.0-10ubuntu2.6+esm1
Update to 2.2.0-10ubuntu2.6+esm1
openexr Ubuntu:18.04:LTS
- Versions
- 2.2.0-11ubuntu1
- 2.2.0-11.1ubuntu1
- 2.2.0-11.1ubuntu1.1
- 2.2.0-11.1ubuntu1.2
- 2.2.0-11.1ubuntu1.3
- 2.2.0-11.1ubuntu1.4
- 2.2.0-11.1ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 2.2.0-11.1ubuntu1.7
Update to 2.2.0-11.1ubuntu1.7
openexr Ubuntu:Pro:20.04:LTS
- Versions
- 2.2.1-4.1ubuntu1
- 2.3.0-6
- 2.3.0-6build1
- 2.3.0-6ubuntu0.1
- 2.3.0-6ubuntu0.2
- 2.3.0-6ubuntu0.3
- 2.3.0-6ubuntu0.5
- Affected ranges
- ECOSYSTEM: < 2.3.0-6ubuntu0.5+esm1
Update to 2.3.0-6ubuntu0.5+esm1
Original sources
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BXFLD4ZAXKAIWO6ZPBCQEEDZB5IG676K/
- https://bugzilla.redhat.com/show_bug.cgi?id=1947582
- https://lists.debian.org/debian-lts-announce/2021/07/msg00001.html
- https://www.debian.org/security/2022/dsa-5299
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-26260