CVE-2021-27913
CVE-2021-27913 · Use of a Broken or Risky Cryptographic Algorithm
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The function mt_rand is used to generate session tokens, this function is cryptographically flawed due to its nature being one pseudorandomness, an attacker can take advantage of the cryptographically insecure nature of this function to enumerate session tokens for accounts that are not under his/her control This issue affects: Mautic Mautic versions prior to 3.3.4; versions prior to 4.0.0.
CVSS 3.5 · Low · EPSS 0.5% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
mautic
- Versions
- ≥ unspecified, < 3.3.4: Affected (custom)
- ≥ unspecified, < 4.0.0: Affected (custom)
Update to 3.3.4
mautic/core Packagist
- Versions
- 1.0.0
- 1.0.0-beta
- 1.0.0-beta2
- 1.0.0-beta3
- 1.0.0-beta4
- 1.0.0-rc1
- 1.0.0-rc2
- 1.0.0-rc3
- 1.0.0-rc4
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.2.0
- 1.2.0-beta1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- 1.3.0
- 1.3.1
- 1.4.0
- 1.4.1
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.10.0
- 2.10.0-beta
- 2.10.1
- 2.11.0
- 2.11.0-beta
- 2.12.0
- 2.12.0-beta
- 2.12.1
- 2.12.1-beta
- 2.12.2
- 2.12.2-beta
- 2.13.0
- 2.13.0-beta
- 2.13.1
- 2.14.0
- 2.14.0-beta
- 2.14.1
- 2.14.1-beta
- 2.14.2
- 2.14.2-beta
- 2.15.0
- 2.15.0-beta
- 2.15.1
- 2.15.1-beta
- 2.15.2
- 2.15.2-beta
- 2.15.3
- 2.15.3-beta
- 2.16.0
- 2.16.0-beta
- 2.16.1
- 2.16.1-beta
- 2.16.2
- 2.16.2-beta
- 2.16.3
- 2.16.3-beta
- 2.16.4
- 2.16.5
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.9.0
- 2.9.0-beta
- 2.9.1
- 2.9.2
- 3.0.0
- 3.0.0-alpha
- 3.0.0-beta
- 3.0.0-beta2
- 3.0.1
- 3.0.2
- 3.0.2-rc
- 3.1.0
- 3.1.0-rc
- 3.1.1
- 3.1.1-rc
- 3.1.2
- 3.1.2-rc
- 3.2.0
- 3.2.0-rc
- 3.2.1
- 3.2.2
- 3.2.2-rc
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.5-rc
- 3.3.0
- 3.3.0-rc
- 3.3.1
- 3.3.2
- 3.3.2-rc
- 3.3.3
- 3.3.3-rc
- Affected ranges
- ECOSYSTEM: < 3.3.4
Update to 3.3.4
mautic/core Packagist
- Versions
- 4.0.0-alpha1
- 4.0.0-beta
- 4.0.0-rc
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0-alpha1, < 4.0.0
Update to 4.0.0