CVE-2021-28706
CVE-2021-28706
This page contains facts from public vulnerability sources. Check the original advisory before updating.
guests may exceed their designated memory limit When a guest is permitted to have close to 16TiB of memory, it may be able to issue hypercalls to increase its memory allocation beyond the administrator established limit. This is a result of a calculation done with 32-bit precision, which may overflow. It would then only be the overflowed (and hence small) number which gets compared against the established upper bound.
CVSS 8.6 · High · EPSS 2.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
xen
- Versions
- 4.12.x: Affected
No fix published
xen
- Versions
- ≥ unspecified, < 4.12: Unknown (custom)
- ≥ 4.14.x, < unspecified: Affected (custom)
- ≥ next of 4.15.x, < unspecified: Not affected (custom)
No fix published
xen
- Versions
- xen-unstable: Affected
No fix published
xen
- Versions
- 4.13.x: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.14.3+32-g9de3671772-1
Update to 4.14.3+32-g9de3671772-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.14.3+32-g9de3671772-1
Update to 4.14.3+32-g9de3671772-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.14.3+32-g9de3671772-1
Update to 4.14.3+32-g9de3671772-1
xen Ubuntu:16.04:LTS
- Versions
- 4.5.1-0ubuntu1
- 4.5.1-0ubuntu2
- 4.6.0-1ubuntu1
- 4.6.0-1ubuntu2
- 4.6.0-1ubuntu4
- 4.6.0-1ubuntu4.1
- 4.6.0-1ubuntu4.2
- 4.6.0-1ubuntu4.3
- 4.6.5-0ubuntu1
- 4.6.5-0ubuntu1.1
- 4.6.5-0ubuntu1.2
- 4.6.5-0ubuntu1.4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:18.04:LTS
- Versions
- 4.9.0-0ubuntu3
- 4.9.0-0ubuntu4
- 4.9.2-0ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:20.04:LTS
- Versions
- 4.9.2-0ubuntu2
- 4.9.2-0ubuntu6
- 4.9.2-0ubuntu7
- 4.11.3+24-g14b62ab3e5-1ubuntu1
- 4.11.3+24-g14b62ab3e5-1ubuntu2
- 4.11.3+24-g14b62ab3e5-1ubuntu2.2
- 4.11.3+24-g14b62ab3e5-1ubuntu2.3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:22.04:LTS
- Versions
- 4.11.4+24-gddaaccbbab-1ubuntu2
- 4.16.0-1~ubuntu2
- 4.16.0-1~ubuntu2.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:24.04:LTS
- Versions
- 4.17.2-1
- 4.17.2+55-g0b56bed864-1
- 4.17.2+76-ge1f9cb16e2-1
- 4.17.2+76-ge1f9cb16e2-1ubuntu1
- 4.17.3+10-g091466ba55-1
- 4.17.3+10-g091466ba55-1.1ubuntu2
- 4.17.3+10-g091466ba55-1.1ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:25.10
- Versions
- 4.20.0-1ubuntu1
- 4.20.0+68-g35cb38b222-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:26.10
- Versions
- 4.20.2+7-g1badcf5035-2build2
- 4.20.2+37-g61ff35323e-1ubuntu1
- 4.20.3+127-gc42374a105-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:26.04:LTS
- Versions
- 4.20.0+68-g35cb38b222-1
- 4.20.2+7-g1badcf5035-2
- 4.20.2+7-g1badcf5035-2build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://xenbits.xenproject.org/xsa/advisory-385.txt
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/I7ZGWVVRI4XY2XSTBI3XEMWBXPDVX6OT/
- https://www.debian.org/security/2021/dsa-5017
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PXUI4VMD52CH3T7YXAG3J2JW7ZNN3SXF/
- https://security.gentoo.org/glsa/202402-07
- https://nvd.nist.gov/vuln/detail/CVE-2021-28706