CVE-2021-28876
CVE-2021-28876
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In the standard library in Rust before 1.52.0, the Zip implementation has a panic safety issue. It calls __iterator_get_unchecked() more than once for the same index when the underlying iterator panics (in certain conditions). This bug could lead to a memory safety violation due to an unmet safety requirement for the TrustedRandomAccess trait.
CVSS 5.3 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
rustc Debian:12
- Affected ranges
- ECOSYSTEM: < 1.53.0+dfsg1-1
Update to 1.53.0+dfsg1-1
rustc Debian:13
- Affected ranges
- ECOSYSTEM: < 1.53.0+dfsg1-1
Update to 1.53.0+dfsg1-1
rustc Debian:14
- Affected ranges
- ECOSYSTEM: < 1.53.0+dfsg1-1
Update to 1.53.0+dfsg1-1
rustc Ubuntu:Pro:14.04:LTS
- Versions
- 1.15.1+dfsg0-1~exp1ubuntu2~14.04.7
- 1.17.0+dfsg2-8~ubuntu0.14.04.3
- 1.21.0+dfsg1+llvm-0ubuntu3~14.04.5
- 1.22.1+dfsg1+llvm-0ubuntu2~14.04.2
- 1.24.1+dfsg1+llvm-0ubuntu1~14.04.1
- 1.25.0+dfsg1+llvm-0ubuntu1~14.04.1
- 1.28.0+dfsg1+llvm-0ubuntu1~14.04.1
- 1.30.0+dfsg1+llvm-2ubuntu1~14.04.1
- 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1
- 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rustc Ubuntu:Pro:16.04:LTS
- Versions
- 1.7.0+dfsg1-1
- 1.15.1+dfsg0-1~exp1ubuntu2~16.04.3
- 1.17.0+dfsg2-8~ubuntu0.16.04.2
- 1.21.0+dfsg1+llvm-0ubuntu3~16.04.1
- 1.22.1+dfsg1+llvm-0ubuntu2~16.04.2
- 1.24.1+dfsg1+llvm-0ubuntu1~16.04.1
- 1.25.0+dfsg1+llvm-0ubuntu1~16.04.1
- 1.28.0+dfsg1+llvm-0ubuntu1~16.04.1
- 1.30.0+dfsg1+llvm-2ubuntu1~16.04.1
- 1.31.0+dfsg1+llvm-2ubuntu1~16.04.1
- 1.32.0+dfsg1+llvm-1ubuntu1~16.04.1
- 1.34.1+dfsg2+llvm-0ubuntu1~16.04.1
- 1.35.0+dfsg0.1+llvm-0ubuntu1~16.04.1
- 1.36.0+dfsg1+llvm-2ubuntu1~16.04.1
- 1.37.0+dfsg1+llvm-1ubuntu1~16.04.1
- 1.39.0+dfsg1+llvm-3ubuntu1~16.04.1
- 1.41.0+dfsg1+llvm-0ubuntu1~16.04.1
- 1.43.0+dfsg1+llvm-1~exp1ubuntu2~16.04.1
- 1.47.0+dfsg1+llvm-1ubuntu1~16.04.1
- 1.47.0+dfsg1+llvm-1ubuntu1~16.04.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rustc Ubuntu:20.04:LTS
- Versions
- 1.37.0+dfsg1+llvm-1ubuntu1
- 1.38.0+dfsg0.2+llvm-0ubuntu1
- 1.38.0+dfsg0.2+llvm-0ubuntu2
- 1.39.0+dfsg1+llvm-3ubuntu1
- 1.40.0+dfsg1+llvm-5ubuntu1
- 1.41.0+dfsg1+llvm-0ubuntu1
- 1.41.0+dfsg1+llvm-0ubuntu2
- 1.43.0+dfsg1+llvm-1~exp1ubuntu1~20.04.1
- 1.47.0+dfsg1+llvm-1ubuntu1~20.04.1
- 1.51.0+dfsg1+llvm-1~exp3ubuntu1~20.04.2
- Affected ranges
- ECOSYSTEM: < 1.53.0+dfsg1+llvm-4ubuntu1~20.04.1
Update to 1.53.0+dfsg1+llvm-4ubuntu1~20.04.1
rustc Ubuntu:22.04:LTS
- Versions
- 1.51.0+dfsg1+llvm-1~exp3ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.53.0+dfsg1+llvm-4ubuntu1
Update to 1.53.0+dfsg1+llvm-4ubuntu1
Original sources
- https://github.com/rust-lang/rust/issues/81740
- https://github.com/rust-lang/rust/pull/81741
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CZ337CM4GFJLRDFVQCGC7J25V65JXOG5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VZG65GUW6Z2CYOQHF7T3TB5CZKIX6ZJE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TFUO3URYCO73D2Q4WYJBWAMJWGGVXQO4/
- https://security.gentoo.org/glsa/202210-09
- https://nvd.nist.gov/vuln/detail/CVE-2021-28876