CVE-2021-29454
CVE-2021-29454 · Sandbox Escape by math function in smarty
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.
CVSS 8.1 · High · EPSS 1.8% · Fix available
- Published
- Updated
Affected products and versions
smarty
- Versions
- < 3.1.42: Affected
- >= 4.0.0, < 4.0.2: Affected
No fix published
smarty3 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.1.45-1
Update to 3.1.45-1
smarty3 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.45-1
Update to 3.1.45-1
smarty3 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.1.45-1
Update to 3.1.45-1
smarty4 Debian:12
- Affected ranges
- ECOSYSTEM: < 4.1.1-1
Update to 4.1.1-1
smarty4 Debian:13
- Affected ranges
- ECOSYSTEM: < 4.1.1-1
Update to 4.1.1-1
smarty4 Debian:14
- Affected ranges
- ECOSYSTEM: < 4.1.1-1
Update to 4.1.1-1
smarty/smarty Packagist
- Versions
- v2.6.24
- v2.6.25
- v2.6.26
- v2.6.27
- v2.6.28
- v2.6.29
- v2.6.30
- v2.6.31
- v2.6.33
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- v3.1.32
- v3.1.33
- v3.1.34
- v3.1.35
- v3.1.36
- v3.1.37
- v3.1.37.1
- v3.1.38
- v3.1.39
- v3.1.40
- v3.1.41
- Affected ranges
- ECOSYSTEM: < 3.1.42
Update to 3.1.42
smarty/smarty Packagist
- Versions
- v4.0.0
- v4.0.1
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.0.2
Update to 4.0.2
smarty3 Ubuntu:Pro:16.04:LTS
- Versions
- 3.1.21-1
- 3.1.21-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 3.1.21-1ubuntu1+esm1
Update to 3.1.21-1ubuntu1+esm1
smarty3 Ubuntu:18.04:LTS
- Versions
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- 3.1.31+20161214.1.c7d42e4+selfpack1-3
- Affected ranges
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
Update to 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
smarty3 Ubuntu:Pro:20.04:LTS
- Versions
- 3.1.33+20180830.1.3a78a21f+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1
- Affected ranges
- ECOSYSTEM: < 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1
Update to 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1
smarty3 Ubuntu:22.04:LTS
- Versions
- 3.1.39-2
- Affected ranges
- ECOSYSTEM: < 3.1.39-2ubuntu1
Update to 3.1.39-2ubuntu1
Original sources
- https://github.com/smarty-php/smarty/security/advisories/GHSA-29gp-2c3m-3j6m
- https://github.com/smarty-php/smarty/commit/215d81a9fa3cd63d82fb3ab56ecaf97cf1e7db71
- https://github.com/smarty-php/smarty/releases/tag/v3.1.42
- https://github.com/smarty-php/smarty/releases/tag/v4.0.2
- https://packagist.org/packages/smarty/smarty
- https://www.smarty.net/docs/en/language.function.math.tpl
- https://lists.debian.org/debian-lts-announce/2022/05/msg00005.html
- https://www.debian.org/security/2022/dsa-5151
- https://security.gentoo.org/glsa/202209-09
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L777JIBIWJV34HS7LXPIDWASG7TT4LNI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BRAJVDRGCIY5UZ2PQHKDTT7RMKG6WJQQ/
- https://nvd.nist.gov/vuln/detail/CVE-2021-29454