p PatchFirst

CVE-2021-29457

CVE-2021-29457 · Heap buffer overflow in Exiv2::Jp2Image::doWriteMetadata

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A heap buffer overflow was found in Exiv2 versions v0.27.3 and earlier. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when _writing_ the metadata, which is a less frequently used Exiv2 operation than _reading_ the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `insert`. The bug is fixed in version v0.27.4.

CVSS 7.8 · High · EPSS 2.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • exiv2

    Versions
    • < 0.27.4: Affected

    No fix published

  • exiv2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.27.3-3.1

    Update to 0.27.3-3.1

  • exiv2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.27.3-3.1

    Update to 0.27.3-3.1

  • exiv2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.27.3-3.1

    Update to 0.27.3-3.1

  • exiv2 Ubuntu:Pro:16.04:LTS

    Versions
    • 0.25-1ubuntu1
    • 0.25-2.1
    • 0.25-2.1ubuntu16.04.1
    • 0.25-2.1ubuntu16.04.2
    • 0.25-2.1ubuntu16.04.3
    • 0.25-2.1ubuntu16.04.4
    • 0.25-2.1ubuntu16.04.5
    • 0.25-2.1ubuntu16.04.6
    Affected ranges
    • ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm1

    Update to 0.25-2.1ubuntu16.04.7+esm1

  • exiv2 Ubuntu:18.04:LTS

    Versions
    • 0.25-3.1
    • 0.25-3.1ubuntu0.18.04.1
    • 0.25-3.1ubuntu0.18.04.2
    • 0.25-3.1ubuntu0.18.04.3
    • 0.25-3.1ubuntu0.18.04.4
    • 0.25-3.1ubuntu0.18.04.5
    Affected ranges
    • ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.7

    Update to 0.25-3.1ubuntu0.18.04.7

  • exiv2 Ubuntu:20.04:LTS

    Versions
    • 0.25-4ubuntu2
    • 0.25-4ubuntu3
    • 0.27.2-8ubuntu2
    Affected ranges
    • ECOSYSTEM: < 0.27.2-8ubuntu2.2

    Update to 0.27.2-8ubuntu2.2

Original sources

Check your server →