CVE-2021-29473
CVE-2021-29473 · Out-of-bounds read in Exiv2::Jp2Image::doWriteMetadata
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `insert`. The bug is fixed in version v0.27.4. Please see our security policy for information about Exiv2 security.
CVSS 2.5 · Low · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
exiv2
- Versions
- < 0.27.4: Affected
No fix published
exiv2 Debian:12
- Affected ranges
- ECOSYSTEM: < 0.27.5-1
Update to 0.27.5-1
exiv2 Debian:13
- Affected ranges
- ECOSYSTEM: < 0.27.5-1
Update to 0.27.5-1
exiv2 Debian:14
- Affected ranges
- ECOSYSTEM: < 0.27.5-1
Update to 0.27.5-1
exiv2 Ubuntu:Pro:16.04:LTS
- Versions
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- 0.25-2.1ubuntu16.04.7+esm1
- Affected ranges
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm2
Update to 0.25-2.1ubuntu16.04.7+esm2
exiv2 Ubuntu:18.04:LTS
- Versions
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- 0.25-3.1ubuntu0.18.04.7
- Affected ranges
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.9
Update to 0.25-3.1ubuntu0.18.04.9
exiv2 Ubuntu:20.04:LTS
- Versions
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- 0.27.2-8ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 0.27.2-8ubuntu2.4
Update to 0.27.2-8ubuntu2.4
Original sources
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-7569-phvm-vwc2
- https://github.com/github/advisory-review/pull/1587
- https://github.com/Exiv2/exiv2/security/policy
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2XQT5F5IINTDYDAFGVGQZ7PMMLG7I5ZZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JWZLDECIXXW3CCZ3RS4A3NG5X5VE4WZM/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LBKWLTXM7IKZ4PVGKLUQVAVFAYGGF7QR/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P2A5GMJEXQ5Q76JK6F6VKK5JYCLVFGKN/
- https://www.debian.org/security/2021/dsa-4958
- https://lists.debian.org/debian-lts-announce/2021/08/msg00028.html
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-29473