CVE-2021-29512
CVE-2021-29512 · Heap buffer overflow in `RaggedBinCount`
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TensorFlow is an end-to-end open source platform for machine learning. If the `splits` argument of `RaggedBincount` does not specify a valid `SparseTensor`(https://www.tensorflow.org/api_docs/python/tf/sparse/SparseTensor), then an attacker can trigger a heap buffer overflow. This will cause a read from outside the bounds of the `splits` tensor buffer in the implementation of the `RaggedBincount` op(https://github.com/tensorflow/tensorflow/blob/8b677d79167799f71c42fd3fa074476e0295413a/tensorflow/core/kernels/bincount_op.cc#L430-L433). Before the `for` loop, `batch_idx` is set to 0. The user controls the `splits` array, making it contain only one element, 0. Thus, the code in the `while` loop would increment `batch_idx` and then try to read `splits(1)`, which is outside of bounds. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2 and TensorFlow 2.3.3, as these are also affected.
CVSS 2.5 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- >=2.3.0, < 2.3.3: Affected
- >= 2.4.0, < 2.4.2: Affected
No fix published
tensorflow PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3
Update to 2.3.3
tensorflow PyPI
- Versions
- 2.4.0
- 2.4.1
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.2
Update to 2.4.2
tensorflow-cpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3
Update to 2.3.3
tensorflow-cpu PyPI
- Versions
- 2.4.0
- 2.4.1
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.2
Update to 2.4.2
tensorflow-gpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3
Update to 2.3.3
tensorflow-gpu PyPI
- Versions
- 2.4.0
- 2.4.1
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.2
Update to 2.4.2
tensorflow PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- Affected ranges
- GIT: < eebb96c2830d48597d055d247c0e9aebaea94cd5
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3 ∪ ≥ 2.4.0, < 2.4.2
Update to 2.3.3; Update to 2.4.2
tensorflow-cpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- Affected ranges
- GIT: < eebb96c2830d48597d055d247c0e9aebaea94cd5
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3 ∪ ≥ 2.4.0, < 2.4.2
Update to 2.3.3; Update to 2.4.2
tensorflow-gpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- Affected ranges
- GIT: < eebb96c2830d48597d055d247c0e9aebaea94cd5
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3 ∪ ≥ 2.4.0, < 2.4.2
Update to 2.3.3; Update to 2.4.2