CVE-2021-29611
CVE-2021-29611 · Incomplete validation in `SparseReshape`
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TensorFlow is an end-to-end open source platform for machine learning. Incomplete validation in `SparseReshape` results in a denial of service based on a `CHECK`-failure. The implementation(https://github.com/tensorflow/tensorflow/blob/e87b51ce05c3eb172065a6ea5f48415854223285/tensorflow/core/kernels/sparse_reshape_op.cc#L40) has no validation that the input arguments specify a valid sparse tensor. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2 and TensorFlow 2.3.3, as these are the only affected versions.
CVSS 3.6 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- < 2.3.3: Affected
- >= 2.4.0, < 2.4.2: Affected
No fix published
tensorflow PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3
Update to 2.3.3
tensorflow PyPI
- Versions
- 2.4.0
- 2.4.1
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.2
Update to 2.4.2
tensorflow-cpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3
Update to 2.3.3
tensorflow-cpu PyPI
- Versions
- 2.4.0
- 2.4.1
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.2
Update to 2.4.2
tensorflow-gpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.3
Update to 2.3.3
tensorflow-gpu PyPI
- Versions
- 2.4.0
- 2.4.1
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.2
Update to 2.4.2
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.0rc0
- 0.12.0rc1
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.0rc0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc0
- 1.10.0rc1
- 1.10.1
- 1.11.0
- 1.11.0rc0
- 1.11.0rc1
- 1.11.0rc2
- 1.12.0
- 1.12.0rc0
- 1.12.0rc1
- 1.12.0rc2
- 1.12.2
- 1.12.3
- 1.13.0rc0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.1
- 1.13.2
- 1.14.0
- 1.14.0rc0
- 1.14.0rc1
- 1.15.0
- 1.15.0rc0
- 1.15.0rc1
- 1.15.0rc2
- 1.15.0rc3
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.0rc0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.3.0
- 1.3.0rc0
- 1.3.0rc1
- 1.3.0rc2
- 1.4.0
- 1.4.0rc0
- 1.4.0rc1
- 1.4.1
- 1.5.0
- 1.5.0rc0
- 1.5.0rc1
- 1.5.1
- 1.6.0
- 1.6.0rc0
- 1.6.0rc1
- 1.7.0
- 1.7.0rc0
- 1.7.0rc1
- 1.7.1
- 1.8.0
- 1.8.0rc0
- 1.8.0rc1
- 1.9.0
- 1.9.0rc0
- 1.9.0rc1
- 1.9.0rc2
- 2.0.0
- 2.0.0a0
- 2.0.0b0
- 2.0.0b1
- 2.0.0rc0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.0rc0
- 2.1.0rc1
- 2.1.0rc2
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- Affected ranges
- GIT: < 1d04d7d93f4ed3854abf75d6b712d72c3f70d6b6
- ECOSYSTEM: < 2.1.4 ∪ ≥ 2.2.0, < 2.2.3 ∪ ≥ 2.3.0, < 2.3.3 ∪ ≥ 2.4.0, < 2.4.2
Update to 2.1.4; Update to 2.2.3; Update to 2.3.3; Update to 2.4.2
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- Affected ranges
- GIT: < 1d04d7d93f4ed3854abf75d6b712d72c3f70d6b6
- ECOSYSTEM: < 2.1.4 ∪ ≥ 2.2.0, < 2.2.3 ∪ ≥ 2.3.0, < 2.3.3 ∪ ≥ 2.4.0, < 2.4.2
Update to 2.1.4; Update to 2.2.3; Update to 2.3.3; Update to 2.4.2
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- Affected ranges
- GIT: < 1d04d7d93f4ed3854abf75d6b712d72c3f70d6b6
- ECOSYSTEM: < 2.1.4 ∪ ≥ 2.2.0, < 2.2.3 ∪ ≥ 2.3.0, < 2.3.3 ∪ ≥ 2.4.0, < 2.4.2
Update to 2.1.4; Update to 2.2.3; Update to 2.3.3; Update to 2.4.2