CVE-2021-29950
CVE-2021-29950
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Thunderbird unprotects a secret OpenPGP key prior to using it for a decryption, signing or key import task. If the task runs into a failure, the secret key may remain in memory in its unprotected state. This vulnerability affects Thunderbird < 78.8.1.
CVSS 7.5 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
thunderbird
- Versions
- ≥ unspecified, < 78.8.1: Affected (custom)
Update to 78.8.1
thunderbird Debian:12
- Affected ranges
- ECOSYSTEM: < 1:78.9.0-1
Update to 1:78.9.0-1
thunderbird Debian:13
- Affected ranges
- ECOSYSTEM: < 1:78.9.0-1
Update to 1:78.9.0-1
thunderbird Debian:14
- Affected ranges
- ECOSYSTEM: < 1:78.9.0-1
Update to 1:78.9.0-1
thunderbird Ubuntu:18.04:LTS
- Versions
- 1:52.4.0+build1-0ubuntu2
- 1:52.6.0+build1-0ubuntu1
- 1:52.7.0+build1-0ubuntu1
- 1:52.8.0+build1-0ubuntu0.18.04.1
- 1:52.9.1+build3-0ubuntu0.18.04.1
- 1:60.2.1+build1-0ubuntu0.18.04.2
- 1:60.4.0+build2-0ubuntu0.18.04.1
- 1:60.5.1+build2-0ubuntu0.18.04.1
- 1:60.6.1+build2-0ubuntu0.18.04.1
- 1:60.7.0+build1-0ubuntu0.18.04.1
- 1:60.7.1+build1-0ubuntu0.18.04.1
- 1:60.7.2+build2-0ubuntu0.18.04.1
- 1:60.8.0+build1-0ubuntu0.18.04.1
- 1:60.9.0+build1-0ubuntu0.18.04.1
- 1:68.2.1+build1-0ubuntu0.18.04.1
- 1:68.2.2+build1-0ubuntu0.18.04.1
- 1:68.4.1+build1-0ubuntu0.18.04.1
- 1:68.7.0+build1-0ubuntu0.18.04.1
- 1:68.8.0+build2-0ubuntu0.18.04.2
- 1:68.10.0+build1-0ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 1:78.8.1+build1-0ubuntu0.18.04.1
Update to 1:78.8.1+build1-0ubuntu0.18.04.1
thunderbird Ubuntu:20.04:LTS
- Versions
- 1:68.1.2+build1-0ubuntu1
- 1:68.1.2+build1-0ubuntu2
- 1:68.2.1+build1-0ubuntu1
- 1:68.2.2+build1-0ubuntu1
- 1:68.3.0+build2-0ubuntu1
- 1:68.3.1+build1-0ubuntu2
- 1:68.4.1+build1-0ubuntu1
- 1:68.4.2+build2-0ubuntu1
- 1:68.5.0+build1-0ubuntu1
- 1:68.6.0+build2-0ubuntu1
- 1:68.7.0+build1-0ubuntu1
- 1:68.7.0+build1-0ubuntu2
- 1:68.8.0+build2-0ubuntu0.20.04.2
- 1:68.10.0+build1-0ubuntu0.20.04.1
- 1:78.7.1+build1-0ubuntu0.20.04.1
- Affected ranges
- ECOSYSTEM: < 1:78.8.1+build1-0ubuntu0.20.04.1
Update to 1:78.8.1+build1-0ubuntu0.20.04.1