CVE-2021-30640
CVE-2021-30640 · Auth weakness in JNDIRealm
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in the JNDI Realm of Apache Tomcat allows an attacker to authenticate using variations of a valid user name and/or to bypass some of the protection provided by the LockOut Realm. This issue affects Apache Tomcat 10.0.0-M1 to 10.0.5; 9.0.0.M1 to 9.0.45; 8.5.0 to 8.5.65.
CVSS 6.5 · Medium · EPSS 9.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat
- Versions
- Apache Tomcat 10 10.0.0-M1 to 10.0.5: Affected
- Apache Tomcat 9 9.0.0.M1 to 9.0.45: Affected
- Apache Tomcat 8.5 8.5.0 to 8.5.65: Affected
- Apache Tomcat 7 7.0.0 to 7.0.108: Affected
No fix published
tomcat9 Debian:12
- Affected ranges
- ECOSYSTEM: < 9.0.43-2
Update to 9.0.43-2
tomcat9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.0.43-2
Update to 9.0.43-2
tomcat9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.0.43-2
Update to 9.0.43-2
tomcat6 Ubuntu:Pro:14.04:LTS
- Versions
- 6.0.37-1
- 6.0.39-1
- 6.0.39-1ubuntu0.1
- 6.0.39-1ubuntu0.1+esm1
- 6.0.39-1ubuntu0.1+esm2
- 6.0.39-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat7 Ubuntu:Pro:14.04:LTS
- Versions
- 7.0.42-1
- 7.0.47-1
- 7.0.50-1
- 7.0.52-1
- 7.0.52-1ubuntu0.1
- 7.0.52-1ubuntu0.3
- 7.0.52-1ubuntu0.6
- 7.0.52-1ubuntu0.7
- 7.0.52-1ubuntu0.8
- 7.0.52-1ubuntu0.9
- 7.0.52-1ubuntu0.10
- 7.0.52-1ubuntu0.11
- 7.0.52-1ubuntu0.13
- 7.0.52-1ubuntu0.14
- 7.0.52-1ubuntu0.15
- 7.0.52-1ubuntu0.16
- 7.0.52-1ubuntu0.16+esm1
- 7.0.52-1ubuntu0.16+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat8 Ubuntu:Pro:16.04:LTS
- Versions
- 8.0.26-1
- 8.0.28-1
- 8.0.30-1
- 8.0.32-1
- 8.0.32-1ubuntu1
- 8.0.32-1ubuntu1.1
- 8.0.32-1ubuntu1.2
- 8.0.32-1ubuntu1.3
- 8.0.32-1ubuntu1.4
- 8.0.32-1ubuntu1.5
- 8.0.32-1ubuntu1.6
- 8.0.32-1ubuntu1.7
- 8.0.32-1ubuntu1.8
- 8.0.32-1ubuntu1.9
- 8.0.32-1ubuntu1.10
- 8.0.32-1ubuntu1.11
- 8.0.32-1ubuntu1.13
- 8.0.32-1ubuntu1.13+esm1
- 8.0.32-1ubuntu1.13+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat7 Ubuntu:Pro:16.04:LTS
- Versions
- 7.0.64-1
- 7.0.68-1
- 7.0.68-1ubuntu0.1
- 7.0.68-1ubuntu0.3
- 7.0.68-1ubuntu0.4
- 7.0.68-1ubuntu0.4+esm1
- 7.0.68-1ubuntu0.4+esm2
- 7.0.68-1ubuntu0.4+esm3
- 7.0.68-1ubuntu0.4+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat9 Ubuntu:18.04:LTS
- Versions
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2
Update to 9.0.16-3ubuntu0.18.04.2
tomcat8 Ubuntu:Pro:18.04:LTS
- Versions
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- 8.5.39-1ubuntu1~18.04.3+esm5
- 8.5.39-1ubuntu1~18.04.3+esm6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat9 Ubuntu:20.04:LTS
- Versions
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 9.0.31-1ubuntu0.2
Update to 9.0.31-1ubuntu0.2
Original sources
- https://lists.apache.org/thread.html/r59f9ef03929d32120f91f4ea7e6e79edd5688d75d0a9b65fd26d1fe8%40%3Cannounce.tomcat.apache.org%3E
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://lists.debian.org/debian-lts-announce/2021/08/msg00009.html
- https://www.debian.org/security/2021/dsa-4952
- https://www.debian.org/security/2021/dsa-4986
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://security.netapp.com/advisory/ntap-20210827-0007/
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://security.gentoo.org/glsa/202208-34
- https://nvd.nist.gov/vuln/detail/CVE-2021-30640