CVE-2021-3115
CVE-2021-3115
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Go before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the "go get" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).
CVSS 7.5 · High · EPSS 6.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
golang-1.15 Debian:11
- Affected ranges
- ECOSYSTEM: < 1.15.7-1
Update to 1.15.7-1
Original sources
- https://groups.google.com/g/golang-announce/c/mperVMGa98w
- https://blog.golang.org/path-security
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YWAYJGXWC232SG3UR3TR574E6BP3OSQQ/
- https://security.netapp.com/advisory/ntap-20210219-0001/
- https://security.gentoo.org/glsa/202208-02
- https://nvd.nist.gov/vuln/detail/CVE-2021-3115