p PatchFirst

CVE-2021-32066

CVE-2021-32066

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. Net::IMAP does not raise an exception when StartTLS fails with an an unknown response, which might allow man-in-the-middle attackers to bypass the TLS protections by leveraging a network position between the client and the registry to block the StartTLS command, aka a "StartTLS stripping attack."

CVSS 7.4 · High · EPSS 2.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jruby Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.3.9.0+ds-1

    Update to 9.3.9.0+ds-1

  • jruby Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.3.9.0+ds-1

    Update to 9.3.9.0+ds-1

  • jruby Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.3.9.0+ds-1

    Update to 9.3.9.0+ds-1

  • ruby2.3 Ubuntu:Pro:16.04:LTS

    Versions
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    • 2.3.1-2~16.04.6
    • 2.3.1-2~16.04.7
    • 2.3.1-2~16.04.9
    • 2.3.1-2~16.04.10
    • 2.3.1-2~16.04.11
    • 2.3.1-2~16.04.12
    • 2.3.1-2~ubuntu16.04.13
    • 2.3.1-2~ubuntu16.04.14
    • 2.3.1-2~ubuntu16.04.15
    • 2.3.1-2~ubuntu16.04.16
    Affected ranges
    • ECOSYSTEM: < 2.3.1-2~ubuntu16.04.16+esm1

    Update to 2.3.1-2~ubuntu16.04.16+esm1

  • ruby2.5 Ubuntu:18.04:LTS

    Versions
    • 2.5.0~preview1-1ubuntu2
    • 2.5.0-4ubuntu1
    • 2.5.0-4ubuntu4
    • 2.5.0-5ubuntu1
    • 2.5.0-6ubuntu1
    • 2.5.1-1ubuntu1
    • 2.5.1-1ubuntu1.1
    • 2.5.1-1ubuntu1.2
    • 2.5.1-1ubuntu1.4
    • 2.5.1-1ubuntu1.5
    • 2.5.1-1ubuntu1.6
    • 2.5.1-1ubuntu1.7
    • 2.5.1-1ubuntu1.8
    • 2.5.1-1ubuntu1.9
    Affected ranges
    • ECOSYSTEM: < 2.5.1-1ubuntu1.10

    Update to 2.5.1-1ubuntu1.10

  • ruby2.7 Ubuntu:20.04:LTS

    Versions
    • 2.7.0-1
    • 2.7.0-2
    • 2.7.0-3
    • 2.7.0-4
    • 2.7.0-4ubuntu1
    • 2.7.0-5ubuntu1
    • 2.7.0-5ubuntu1.1
    • 2.7.0-5ubuntu1.2
    • 2.7.0-5ubuntu1.3
    • 2.7.0-5ubuntu1.4
    Affected ranges
    • ECOSYSTEM: < 2.7.0-5ubuntu1.5

    Update to 2.7.0-5ubuntu1.5

Original sources

Check your server →