p PatchFirst

CVE-2021-32278

CVE-2021-32278

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in faad2 through 2.10.0. A heap-buffer-overflow exists in the function lt_prediction located in lt_predict.c. It allows an attacker to cause code Execution.

CVSS 7.8 · High · EPSS 1.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • faad2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.10.0-1

    Update to 2.10.0-1

  • faad2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.10.0-1

    Update to 2.10.0-1

  • faad2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.10.0-1

    Update to 2.10.0-1

  • faad2 Ubuntu:Pro:14.04:LTS

    Versions
    • 2.7-8
    • 2.7-8+deb7u1build0.14.04.1
    • 2.7-8+deb8u3build0.14.04.1~esm1
    Affected ranges
    • ECOSYSTEM: < 2.7-8+deb8u3ubuntu0.1~esm1

    Update to 2.7-8+deb8u3ubuntu0.1~esm1

  • faad2 Ubuntu:Pro:16.04:LTS

    Versions
    • 2.8.0~cvs20150510-1
    • 2.8.0~cvs20150510-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 2.8.0~cvs20150510-1ubuntu0.1+esm1

    Update to 2.8.0~cvs20150510-1ubuntu0.1+esm1

  • faad2 Ubuntu:Pro:18.04:LTS

    Versions
    • 2.8.1-2
    • 2.8.5-1
    • 2.8.6-1
    • 2.8.8-1
    Affected ranges
    • ECOSYSTEM: < 2.8.8-1ubuntu0.1~esm1

    Update to 2.8.8-1ubuntu0.1~esm1

  • faad2 Ubuntu:20.04:LTS

    Versions
    • 2.8.8-3.2
    • 2.9.0-1
    • 2.9.1-1
    Affected ranges
    • ECOSYSTEM: < 2.9.1-1ubuntu0.1

    Update to 2.9.1-1ubuntu0.1

  • welle.io Ubuntu:20.04:LTS

    Versions
    • 2.0~beta2-2
    • 2.0-2
    • 2.1-1
    • 2.1-2
    • 2.1-2build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • welle.io Ubuntu:22.04:LTS

    Versions
    • 2.2-1
    • 2.2-1build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • welle.io Ubuntu:24.04:LTS

    Versions
    • 2.4+ds-2
    • 2.4+ds-2build1
    • 2.4+ds-2build3
    • 2.4+ds-2build4
    • 2.4+ds-2build5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • welle.io Ubuntu:25.10

    Versions
    • 2.4+ds-4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • welle.io Ubuntu:26.10

    Versions
    • 2.7+ds-1
    • 2.7+ds-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • welle.io Ubuntu:26.04:LTS

    Versions
    • 2.4+ds-4
    • 2.4+ds-4.1
    • 2.7+ds-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →