p PatchFirst

CVE-2021-32478

CVE-2021-32478

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.

CVSS 6.1 · Medium · EPSS 1.1% · Public exploit · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v3.10.0
    • v3.10.0-beta
    • v3.10.0-rc1
    • v3.10.0-rc2
    • v3.10.1
    • v3.10.2
    • v3.10.3
    Affected ranges
    • ECOSYSTEM: ≥ 3.10, < 3.10.4

    Update to 3.10.4

  • moodle/moodle Packagist

    Versions
    • v3.9.0
    • v3.9.0-beta
    • v3.9.0-rc1
    • v3.9.0-rc2
    • v3.9.0-rc3
    • v3.9.1
    • v3.9.2
    • v3.9.3
    • v3.9.4
    • v3.9.5
    • v3.9.6
    Affected ranges
    • ECOSYSTEM: ≥ 3.9, < 3.9.7

    Update to 3.9.7

  • moodle/moodle Packagist

    Versions
    • v3.8.0
    • v3.8.0-beta
    • v3.8.0-rc1
    • v3.8.1
    • v3.8.2
    • v3.8.3
    • v3.8.4
    • v3.8.5
    • v3.8.6
    • v3.8.7
    • v3.8.8
    Affected ranges
    • ECOSYSTEM: ≥ 3.8, < 3.8.9

    Update to 3.8.9

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →