p PatchFirst

CVE-2021-32561

CVE-2021-32561

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.

CVSS 6.1 · Medium · EPSS 1.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • octoprint PyPI

    Versions
    • 1.3.11
    • 1.3.12
    • 1.3.12rc1
    • 1.3.12rc3
    • 1.4.0
    • 1.4.0rc1
    • 1.4.0rc2
    • 1.4.0rc3
    • 1.4.0rc4
    • 1.4.0rc5
    • 1.4.0rc6
    • 1.4.1
    • 1.4.1rc1
    • 1.4.1rc2
    • 1.4.1rc3
    • 1.4.1rc4
    • 1.4.2
    • 1.5.0
    • 1.5.0rc1
    • 1.5.0rc2
    • 1.5.0rc3
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.6.0rc1
    • 1.6.0rc2
    • 1.6.0rc3
    Affected ranges
    • ECOSYSTEM: < 1.6.0

    Update to 1.6.0

Original sources

Check your server →