p PatchFirst

CVE-2021-32609

CVE-2021-32609 · XSS vulnerability on Explore page

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apache Superset up to and including 1.1 does not sanitize titles correctly on the Explore page. This allows an attacker with Explore access to save a chart with a malicious title, injecting html (including scripts) into the page.

CVSS 5.4 · Medium · EPSS 1.7% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache superset

    Versions
    • ≥ unspecified, ≤ 1.1: Affected (custom)

    No fix published

  • apache-superset PyPI

    Versions
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    Affected ranges
    • ECOSYSTEM: < 1.2.0

    Update to 1.2.0

Original sources

Check your server →