CVE-2021-32610
CVE-2021-32610
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Archive_Tar before 1.4.14, symlinks can refer to targets outside of the extracted archive, a different vulnerability than CVE-2020-36193.
CVSS 7.1 · High · EPSS 73.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php-pear Debian:12
- Affected ranges
- ECOSYSTEM: < 1:1.10.13+submodules+notgz-1
Update to 1:1.10.13+submodules+notgz-1
php-pear Debian:13
- Affected ranges
- ECOSYSTEM: < 1:1.10.13+submodules+notgz-1
Update to 1:1.10.13+submodules+notgz-1
php-pear Debian:14
- Affected ranges
- ECOSYSTEM: < 1:1.10.13+submodules+notgz-1
Update to 1:1.10.13+submodules+notgz-1
drupal/core Packagist
- Versions
- 8.0.0
- 8.0.1
- 8.0.2
- 8.0.3
- 8.0.4
- 8.0.5
- 8.0.6
- 8.1.0
- 8.1.0-beta1
- 8.1.0-beta2
- 8.1.0-rc1
- 8.1.1
- 8.1.10
- 8.1.2
- 8.1.3
- 8.1.4
- 8.1.5
- 8.1.6
- 8.1.7
- 8.1.8
- 8.1.9
- 8.2.0
- 8.2.0-beta1
- 8.2.0-beta2
- 8.2.0-beta3
- 8.2.0-rc1
- 8.2.0-rc2
- 8.2.1
- 8.2.2
- 8.2.3
- 8.2.4
- 8.2.5
- 8.2.6
- 8.2.7
- 8.2.8
- 8.3.0
- 8.3.0-alpha1
- 8.3.0-beta1
- 8.3.0-rc1
- 8.3.0-rc2
- 8.3.1
- 8.3.2
- 8.3.3
- 8.3.4
- 8.3.5
- 8.3.6
- 8.3.7
- 8.3.8
- 8.3.9
- 8.4.0
- 8.4.0-alpha1
- 8.4.0-beta1
- 8.4.0-rc1
- 8.4.0-rc2
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- 8.4.5
- 8.4.6
- 8.4.7
- 8.4.8
- 8.5.0
- 8.5.0-alpha1
- 8.5.0-beta1
- 8.5.0-rc1
- 8.5.1
- 8.5.10
- 8.5.11
- 8.5.12
- 8.5.13
- 8.5.14
- 8.5.15
- 8.5.2
- 8.5.3
- 8.5.4
- 8.5.5
- 8.5.6
- 8.5.7
- 8.5.8
- 8.5.9
- 8.6.0
- 8.6.0-alpha1
- 8.6.0-beta1
- 8.6.0-beta2
- 8.6.0-rc1
- 8.6.1
- 8.6.10
- 8.6.11
- 8.6.12
- 8.6.13
- 8.6.14
- 8.6.15
- 8.6.16
- 8.6.17
- 8.6.18
- 8.6.2
- 8.6.3
- 8.6.4
- 8.6.5
- 8.6.6
- 8.6.7
- 8.6.8
- 8.6.9
- 8.7.0
- 8.7.0-alpha1
- 8.7.0-alpha2
- 8.7.0-beta1
- 8.7.0-beta2
- 8.7.0-rc1
- 8.7.1
- 8.7.10
- 8.7.11
- 8.7.12
- 8.7.13
- 8.7.14
- 8.7.2
- 8.7.3
- 8.7.4
- 8.7.5
- 8.7.6
- 8.7.7
- 8.7.8
- 8.7.9
- 8.8.0
- 8.8.0-alpha1
- 8.8.0-beta1
- 8.8.0-rc1
- 8.8.1
- 8.8.10
- 8.8.11
- 8.8.12
- 8.8.2
- 8.8.3
- 8.8.4
- 8.8.5
- 8.8.6
- 8.8.7
- 8.8.8
- 8.8.9
- 8.9.0
- 8.9.0-beta1
- 8.9.0-beta2
- 8.9.0-beta3
- 8.9.0-rc1
- 8.9.1
- 8.9.10
- 8.9.11
- 8.9.12
- 8.9.13
- 8.9.14
- 8.9.15
- 8.9.16
- 8.9.2
- 8.9.3
- 8.9.4
- 8.9.5
- 8.9.6
- 8.9.7
- 8.9.8
- 8.9.9
- 9.1.0
- 9.1.1
- 9.1.10
- 9.1.2
- 9.1.3
- 9.1.4
- 9.1.5
- 9.1.6
- 9.1.7
- 9.1.8
- 9.1.9
- 9.2.0
- 9.2.1
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.9.17
- ECOSYSTEM: ≥ 9.1.0, < 9.1.11
- ECOSYSTEM: ≥ 9.2.0, < 9.2.2
Update to 8.9.17; Update to 9.1.11; Update to 9.2.2
pear/archive_tar Packagist
- Versions
- 1.3.11
- 1.3.12
- 1.3.13
- 1.3.14
- 1.3.15
- 1.3.16
- 1.4.0
- 1.4.1
- 1.4.10
- 1.4.11
- 1.4.12
- 1.4.13
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.6
- 1.4.7
- 1.4.8
- 1.4.9
- Affected ranges
- ECOSYSTEM: < 1.4.14
Update to 1.4.14
drupal7 Ubuntu:Pro:14.04:LTS
- Versions
- 7.23-1
- 7.24-1
- 7.24-2
- 7.26-1
- 7.26-1ubuntu0.1
- 7.26-1ubuntu0.1+esm1
- 7.26-1ubuntu0.1+esm2
- 7.26-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-pear Ubuntu:Pro:16.04:LTS
- Versions
- 1:1.10.1+submodules+notgz-4
- 1:1.10.1+submodules+notgz-6
- 1:1.10.1+submodules+notgz-6ubuntu0.1
- 1:1.10.1+submodules+notgz-6ubuntu0.2
- 1:1.10.1+submodules+notgz-6ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1:1.10.1+submodules+notgz-6ubuntu0.3+esm1
Update to 1:1.10.1+submodules+notgz-6ubuntu0.3+esm1
drupal7 Ubuntu:Pro:16.04:LTS
- Versions
- 7.38-1
- 7.41-1
- 7.44-1ubuntu1~16.04.0
- 7.44-1ubuntu1~16.04.0+esm1
- 7.44-1ubuntu1~16.04.0+esm2
- 7.44-1ubuntu1~16.04.0+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-pear Ubuntu:18.04:LTS
- Versions
- 1:1.10.5+submodules+notgz-1
- 1:1.10.5+submodules+notgz-1ubuntu1
- 1:1.10.5+submodules+notgz-1ubuntu1.18.04.1
- 1:1.10.5+submodules+notgz-1ubuntu1.18.04.2
- 1:1.10.5+submodules+notgz-1ubuntu1.18.04.3
- Affected ranges
- ECOSYSTEM: < 1:1.10.5+submodules+notgz-1ubuntu1.18.04.4
Update to 1:1.10.5+submodules+notgz-1ubuntu1.18.04.4
php-pear Ubuntu:20.04:LTS
- Versions
- 1:1.10.9+submodules+notgz-1
- 1:1.10.9+submodules+notgz-1ubuntu0.20.04.1
- 1:1.10.9+submodules+notgz-1ubuntu0.20.04.2
- Affected ranges
- ECOSYSTEM: < 1:1.10.9+submodules+notgz-1ubuntu0.20.04.3
Update to 1:1.10.9+submodules+notgz-1ubuntu0.20.04.3
php-pear Ubuntu:22.04:LTS
- Affected ranges
- ECOSYSTEM: < 1:1.10.12+submodules+notgz+20210212-1ubuntu1
Update to 1:1.10.12+submodules+notgz+20210212-1ubuntu1
Original sources
- https://www.drupal.org/sa-core-2021-004
- https://lists.debian.org/debian-lts-announce/2021/07/msg00023.html
- https://github.com/pear/Archive_Tar/releases/tag/1.4.14
- https://github.com/pear/Archive_Tar/commit/b5832439b1f37331fb4f87e67fe4f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G5LTY6COQYNMMHQJ3QIOJHEWCKD4XDFH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CAODVMHGL5MHQWQAQTXQ7G7OE3VQZ7LS/
- https://github.com/pear/Archive_Tar/commit/7789ebb2f34f9e4adb3a4152ad0d1548930a9755
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VJQQYDAOWHD6RDITDRPHFW7WY6BS3V5N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/42GPGVVFTLJYAKRI75IVB5R45NYQGEUR/
- https://nvd.nist.gov/vuln/detail/CVE-2021-32610