p PatchFirst

CVE-2021-32674

CVE-2021-32674 · Remote Code Execution via traversal in TAL expressions

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Zope is an open-source web application server. This advisory extends the previous advisory at https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36 with additional cases of TAL expression traversal vulnerabilities. Most Python modules are not available for using in TAL expressions that you can add through-the-web, for example in Zope Page Templates. This restriction avoids file system access, for example via the 'os' module. But some of the untrusted modules are available indirectly through Python modules that are available for direct use. By default, you need to have the Manager role to add or edit Zope Page Templates through the web. Only sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk. The problem has been fixed in Zope 5.2.1 and 4.6.1. The workaround is the same as for https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36: A site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.

CVSS 8.8 · High · EPSS 1.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • zope

    Versions
    • >= 5.0.0, < 5.2.1: Affected
    • < 4.6.1: Affected

    No fix published

  • zope PyPI

    Versions
    • 5.0
    • 5.1
    • 5.1.1
    • 5.1.2
    • 5.2
    Affected ranges
    • ECOSYSTEM: ≥ 5.0, < 5.2.1

    Update to 5.2.1

  • zope PyPI

    Versions
    • 4.0
    • 4.0b1
    • 4.0b10
    • 4.0b2
    • 4.0b3
    • 4.0b4
    • 4.0b5
    • 4.0b6
    • 4.0b7
    • 4.0b8
    • 4.0b9
    • 4.1
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.2
    • 4.2.1
    • 4.3
    • 4.4
    • 4.4.1
    • 4.4.2
    • 4.4.3
    • 4.4.4
    • 4.5
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.6
    Affected ranges
    • ECOSYSTEM: < 4.6.1

    Update to 4.6.1

  • zope PyPI

    Versions
    • 4.0
    • 4.1
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.2
    • 4.2.1
    • 4.3
    • 4.4
    • 4.4.1
    • 4.4.2
    • 4.4.3
    • 4.4.4
    • 4.5
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.6
    • 5.0
    • 5.1
    • 5.1.1
    • 5.1.2
    • 5.2
    • 5.0a2
    • 5.0a1
    • 4.0b10
    • 4.0b9
    • 4.0b8
    • 4.0b7
    • 4.0b6
    • 4.0b5
    • 4.0b4
    • 4.0b3
    • 4.0b2
    • 4.0b1
    • 4.0a6
    • 4.0a5
    • 4.0a4
    • 4.0a3
    • 4.0a2
    • 4.0a1
    Affected ranges
    • GIT: < 1d897910139e2c0b11984fc9b78c1da1365bec21
    • ECOSYSTEM: ≥ 4.0, < 4.6.1 ∪ ≥ 5.0, < 5.2.1

    Update to 4.6.1; Update to 5.2.1

Original sources

Check your server →