CVE-2021-32758
CVE-2021-32758 · Layout XML Arbitrary Code Fix
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OpenMage Magento LTS is an alternative to the Magento CE official releases. Prior to versions 19.4.15 and 20.0.11, layout XML enabled admin users to execute arbitrary commands via block methods. The latest OpenMage Versions up from v19.4.15 and v20.0.11 have this Issue patched.
CVSS 7.2 · High · EPSS 2.0% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
magento-lts
- Versions
- < 19.4.15: Affected
- >= 20, < 20.0.11: Affected
No fix published
openmage/magento-lts Packagist
- Versions
- 1.9.1.1
- 1.9.2.0
- 1.9.2.1
- 1.9.2.2
- 1.9.2.3
- 1.9.2.4
- 1.9.3.0
- 1.9.3.1
- v19.4.0
- v19.4.1
- v19.4.10
- v19.4.11
- v19.4.12
- v19.4.13
- v19.4.14
- v19.4.2
- v19.4.3
- v19.4.4
- v19.4.5
- v19.4.6
- v19.4.7
- v19.4.8
- v19.4.9
- Affected ranges
- ECOSYSTEM: < 19.4.15
Update to 19.4.15
openmage/magento-lts Packagist
- Versions
- v20.0.0
- v20.0.1
- v20.0.10
- v20.0.11
- v20.0.12
- v20.0.2
- v20.0.3
- v20.0.4
- v20.0.5
- v20.0.6
- v20.0.7
- v20.0.8
- Affected ranges
- ECOSYSTEM: ≥ 20.0.0, < 20.0.13
Update to 20.0.13