CVE-2021-32796
CVE-2021-32796 · Misinterpretation of malicious XML input in xmldom
This page contains facts from public vulnerability sources. Check the original advisory before updating.
xmldom is an open source pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. xmldom versions 0.6.0 and older do not correctly escape special characters when serializing elements removed from their ancestor. This may lead to unexpected syntactic changes during XML processing in some downstream applications. This issue has been resolved in version 0.7.0. As a workaround downstream applications can validate the input and reject the maliciously crafted documents.
CVSS 6.5 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Affected products and versions
xmldom
- Versions
- < 0.7.0: Affected
No fix published
node-xmldom Debian:12
- Affected ranges
- ECOSYSTEM: < 0.7.3-1
Update to 0.7.3-1
node-xmldom Debian:13
- Affected ranges
- ECOSYSTEM: < 0.7.3-1
Update to 0.7.3-1
node-xmldom Debian:14
- Affected ranges
- ECOSYSTEM: < 0.7.3-1
Update to 0.7.3-1
xmldom npm
- Affected ranges
- SEMVER: ≤ 0.6.0
No fix published
@xmldom/xmldom npm
- Affected ranges
- SEMVER: < 0.7.0
Update to 0.7.0
node-xmldom Ubuntu:20.04:LTS
- Versions
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:24.04:LTS
- Versions
- 0.8.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:25.10
- Versions
- 0.9.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.10
- Versions
- 0.9.8-2
- 0.9.10-2
- 0.9.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.04:LTS
- Versions
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published