CVE-2021-32804
CVE-2021-32804 · Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The npm package "tar" (aka node-tar) before versions 6.1.1, 5.0.6, 4.4.14, and 3.3.2 has a arbitrary File Creation/Overwrite vulnerability due to insufficient absolute path sanitization. node-tar aims to prevent extraction of absolute file paths by turning absolute paths into relative paths when the `preservePaths` flag is not set to `true`. This is achieved by stripping the absolute path root from any absolute file paths contained in a tar file. For example `/home/user/.bashrc` would turn into `home/user/.bashrc`. This logic was insufficient when file paths contained repeated path roots such as `////home/user/.bashrc`. `node-tar` would only strip a single path root from such paths. When given an absolute file path with repeating path roots, the resulting path (e.g. `///home/user/.bashrc`) would still resolve to an absolute path, thus allowing arbitrary file creation and overwrite. This issue was addressed in releases 3.2.2, 4.4.14, 5.0.6 and 6.1.1. Users may work around this vulnerability without upgrading by creating a custom `onentry` method which sanitizes the `entry.path` or a `filter` method which removes entries with absolute paths. See referenced GitHub Advisory for details. Be aware of CVE-2021-32803 which fixes a similar bug in later versions of tar.
CVSS 8.2 · High · EPSS 15.1% · Fix available
- Published
- Updated
Affected products and versions
node-tar
- Versions
- < 3.2.2: Affected
- >= 4.0.0, < 4.4.14: Affected
- >= 5.0.0, < 5.0.6: Affected
- >= 6.0.0, < 6.1.1: Affected
No fix published
node-tar Debian:12
- Affected ranges
- ECOSYSTEM: < 6.1.7+~cs11.3.10-1
Update to 6.1.7+~cs11.3.10-1
node-tar Debian:13
- Affected ranges
- ECOSYSTEM: < 6.1.7+~cs11.3.10-1
Update to 6.1.7+~cs11.3.10-1
node-tar Debian:14
- Affected ranges
- ECOSYSTEM: < 6.1.7+~cs11.3.10-1
Update to 6.1.7+~cs11.3.10-1
tar npm
- Affected ranges
- SEMVER: < 3.2.2
Update to 3.2.2
tar npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.4.14
Update to 4.4.14
tar npm
- Affected ranges
- SEMVER: ≥ 5.0.0, < 5.0.6
Update to 5.0.6
tar npm
- Affected ranges
- SEMVER: ≥ 6.0.0, < 6.1.1
Update to 6.1.1
node-tar Ubuntu:Pro:14.04:LTS
- Versions
- 0.1.18-1
- 0.1.18-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:Pro:16.04:LTS
- Versions
- 1.0.3-2
- 1.0.3-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:18.04:LTS
- Versions
- 2.2.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:Pro:20.04:LTS
- Versions
- 4.4.10+ds1-2
- 4.4.10+ds1-2ubuntu1
- 4.4.10+ds1-2ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:22.04:LTS
- Versions
- 6.1.7+~cs11.3.10-1
- 6.1.11+~cs11.3.10-1
- 6.1.11+ds1+~cs6.0.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:24.04:LTS
- Versions
- 6.1.13+~cs7.0.5-1
- 6.1.13+~cs7.0.5-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:25.10
- Versions
- 6.2.1+~cs7.0.8-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:26.10
- Versions
- 6.2.1+ds1+~cs6.1.13-10
- 7.5.22+~4.0.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-tar Ubuntu:26.04:LTS
- Versions
- 6.2.1+~cs7.0.8-1
- 6.2.1+ds1+~cs6.1.13-6
- 6.2.1+ds1+~cs6.1.13-7
- 6.2.1+ds1+~cs6.1.13-10
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.npmjs.com/package/tar
- https://github.com/npm/node-tar/security/advisories/GHSA-3jfq-g458-7qm9
- https://github.com/npm/node-tar/commit/1f036ca23f64a547bdd6c79c1a44bc62e8115da4
- https://www.npmjs.com/advisories/1770
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2021-32804