CVE-2021-32807
CVE-2021-32807 · Remote Code Execution via unsafe classes in otherwise permitted modules
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The module `AccessControl` defines security policies for Python code used in restricted code within Zope applications. Restricted code is any code that resides in Zope's object database, such as the contents of `Script (Python)` objects. The policies defined in `AccessControl` severely restrict access to Python modules and only exempt a few that are deemed safe, such as Python's `string` module. However, full access to the `string` module also allows access to the class `Formatter`, which can be overridden and extended within `Script (Python)` in a way that provides access to other unsafe Python libraries. Those unsafe Python libraries can be used for remote code execution. By default, you need to have the admin-level Zope "Manager" role to add or edit `Script (Python)` objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web - which would be a very unusual configuration to begin with - are at risk. The problem has been fixed in AccessControl 4.3 and 5.2. Only AccessControl versions 4 and 5 are vulnerable, and only on Python 3, not Python 2.7. As a workaround, a site administrator can restrict adding/editing `Script (Python)` objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.
CVSS 4.4 · Medium · EPSS 2.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
accesscontrol
- Versions
- >= 4.0, < 4.3: Affected
- >= 5.0, < 5.2: Affected
No fix published
accesscontrol PyPI
- Versions
- 4.0
- 4.1
- 4.2
- Affected ranges
- ECOSYSTEM: ≥ 4.0, < 4.3
Update to 4.3
accesscontrol PyPI
- Versions
- 5.0
- 5.1
- Affected ranges
- ECOSYSTEM: ≥ 5.0, < 5.2
Update to 5.2
zope PyPI
- Versions
- 4.0
- 4.1
- 4.1.1
- 4.1.2
- 4.1.3
- 4.2
- 4.2.1
- Affected ranges
- ECOSYSTEM: ≥ 4.0, < 4.3
Update to 4.3
zope PyPI
- Versions
- 5.0
- 5.1
- 5.1.1
- 5.1.2
- Affected ranges
- ECOSYSTEM: ≥ 5.0, < 5.2
Update to 5.2
accesscontrol PyPI
- Versions
- 4.0
- 4.1
- 4.2
- 5.0
- 5.1
- Affected ranges
- GIT: < b42dd4badf803bb9fb71ac34cd9cb0c249262f2c
- ECOSYSTEM: ≥ 4.0, < 4.3 ∪ ≥ 5.0, < 5.2
Update to 4.3; Update to 5.2
zope PyPI
- Versions
- 4.0
- 4.1
- 4.1.1
- 4.1.2
- 4.1.3
- 4.2
- 4.2.1
- 5.0
- 5.1
- 5.1.1
- 5.1.2
- 4.0b7
- 4.0b6
- 4.0b5
- 4.0b4
- 4.0b3
- 4.0b2
- 4.0b1
- 4.0a7
- 4.0a6
- 4.0a5
- 3.0.12
- 4.0a3
- 4.0a2
- 4.0a1
- 3.0.11
- 3.0.10
- 3.0.9
- 3.0.8
- 3.0.7
- Affected ranges
- GIT: < b42dd4badf803bb9fb71ac34cd9cb0c249262f2c
- ECOSYSTEM: ≥ 4.0, < 4.3 ∪ ≥ 5.0, < 5.2
Update to 4.3; Update to 5.2
Original sources
- https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-qcx9-j53g-ccgf
- https://github.com/zopefoundation/AccessControl/commit/b42dd4badf803bb9fb71ac34cd9cb0c249262f2c
- https://github.com/zopefoundation/AccessControl/blob/master/CHANGES.rst#51-2021-07-30
- https://nvd.nist.gov/vuln/detail/CVE-2021-32807